mach mercurial-setup is always failure until creating ~/.mozbuild/mercruial directory

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
4 years ago
10 months ago

People

(Reporter: m_kato, Unassigned)

Tracking

Trunk
Unspecified
Linux

Firefox Tracking Flags

(firefox42 affected)

Details

Until creating ~/.mozbuild/mercruial directory, mach mercurial-setup is always failure by the following.


makoto@bot:~/Development/hg.mozilla.org/mozilla-inbound$ ./mach mercurial-setup
Error running mach:

    ['mercurial-setup']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

IOError: [Errno 2] No such file or directory: u'/home/makoto/.mozbuild/mercurial/setup.lastcheck'

  File "/home/makoto/Development/hg.mozilla.org/mozilla-inbound/tools/mercurial/mach_commands.py", line 54, in mercurial_setup
    with open(state_path, 'a'):
To make matters even worse mach now insists on running mercurial-setup, which then results in this bug here:

MacBook-Pro:mozilla-central nohlmeier$ ./mach build
*** MERCURIAL NOT CONFIGURED ***

mach has detected that you have never run `mach mercurial-setup`.

Running this command will ensure your Mercurial version control tool is up
to date and optimally configured for a better, more productive experience
when working on Mozilla projects.

Please run `mach mercurial-setup` now.
MacBook-Pro:mozilla-central nohlmeier$ ./mach mercurial-setup
Error running mach:

    ['mercurial-setup']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

IOError: [Errno 2] No such file or directory: u'/Users/nohlmeier/.mozbuild/mercurial/setup.lastcheck'

  File "/Users/nohlmeier/src/mozilla-central/tools/mercurial/mach_commands.py", line 54, in mercurial_setup
    with open(state_path, 'a'):
https://hg.mozilla.org/mozilla-central/rev/c95ebeebbc5d

Not the mess I wanted to clean up late at night. But landing on central seemed easier than dealing with landing it on the multiple integration repos, especially at this hour.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1184031
Duplicate of this bug: 1184034
Duplicate of this bug: 1184030
This still didn't work for me on up-to-date fx-team which seems to have your patch applied. After some digging, I created ~/.mozbuild/mercurial/ as a workaround.

(In reply to Nils Ohlmeier [:drno] from comment #1)
> To make matters even worse mach now insists on running mercurial-setup,
> which then results in this bug here:
> 
> MacBook-Pro:mozilla-central nohlmeier$ ./mach build
> *** MERCURIAL NOT CONFIGURED ***
> 
> mach has detected that you have never run `mach mercurial-setup`.
> 
> Running this command will ensure your Mercurial version control tool is up
> to date and optimally configured for a better, more productive experience
> when working on Mozilla projects.
> 
> Please run `mach mercurial-setup` now.

I don't understand why build requires mercurial-setup. The above comment surely doesn't explain it and none of the things mercurial-setup did over here seem relevant for building. Is this just an artificially created dependency? Can we please stop doing that?
Severity: normal → critical
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Dao: Comment #7 is not actionable because it does not contain STR and output. Please open a new bug with required details to diagnose.

The reasoning for the change can be found by reading bug 1182677.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(In reply to Gregory Szorc [:gps] from comment #8)
> Dao: Comment #7 is not actionable because it does not contain STR and
> output. Please open a new bug with required details to diagnose.

I updated, pulled and tried to do ./mach build, that's all. I got the same output as documented in comment 1. Not sure what else I could provide you with. As far as I'm concerned I already worked around this, like I said, so I'm not going to file another bug.
(In reply to Dão Gottwald [:dao] from comment #9)
> (In reply to Gregory Szorc [:gps] from comment #8)
> > Dao: Comment #7 is not actionable because it does not contain STR and
> > output. Please open a new bug with required details to diagnose.
> 
> I updated, pulled and tried to do ./mach build, that's all. I got the same
> output as documented in comment 1.

Oh, and obviously I tried to run mercurial-setup after that. That didn't seem to do anything. I did not see the error message from comment 0.
(In reply to Dão Gottwald [:dao] from comment #10)
> (In reply to Dão Gottwald [:dao] from comment #9)
> > (In reply to Gregory Szorc [:gps] from comment #8)
> > > Dao: Comment #7 is not actionable because it does not contain STR and
> > > output. Please open a new bug with required details to diagnose.
> > 
> > I updated, pulled and tried to do ./mach build, that's all. I got the same
> > output as documented in comment 1.
> 
> Oh, and obviously I tried to run mercurial-setup after that. That didn't
> seem to do anything. I did not see the error message from comment 0.

You may think the output is the same. I want to confirm that by having you open a new bug and include output from *your* machine.

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.