mach mercurial-setup fails if the ~/.mozbuild/mercurial folder doesn't exist

RESOLVED DUPLICATE of bug 1183982

Status

RESOLVED DUPLICATE of bug 1183982
3 years ago
8 months ago

People

(Reporter: florian, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox42 affected)

Details

(Reporter)

Description

3 years ago
$ ./mach mercurial-setup
Error running mach:

    ['mercurial-setup']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

IOError: [Errno 2] No such file or directory: u'/Users/florian/.mozbuild/mercurial/setup.lastcheck'

  File "/Users/florian/buildhg/fx-team/tools/mercurial/mach_commands.py", line 54, in mercurial_setup
    with open(state_path, 'a'):



After running:
$ mkdir /Users/florian/.mozbuild/mercurial/
the command worked.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183982

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.