Failure in test_dialer.py in call_screen.wait_for_outgoing_call

RESOLVED DUPLICATE of bug 1184161

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 1184161
3 years ago
3 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: Martijn Wargers (zombie))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
This can be seen on Jenkins:
http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk-319.mozilla-central.nightly.ui.functional.sanity.bitbar/284/testReport/%28root%29/test_dialer_py%20TestDialer_test_dialer_make_call/test_dialer_py_TestDialer_test_dialer_make_call/

TEST-UNEXPECTED-ERROR | test_dialer.py TestDialer.test_dialer_make_call | NoSuchElementException: NoSuchElementException: Unable to locate element: .handled-call.outgoing


Traceback (most recent call last):
  File "/Users/mwargers/.virtualenvs/gaia-py-latest/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer.py", line 27, in test_dialer_make_call
    call_screen.wait_for_outgoing_call()
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/apps/phone/regions/call_screen.py", line 87, in wait_for_outgoing_call
    call = self.marionette.find_element(*self._outgoing_call_locator)
  File "/Users/mwargers/.virtualenvs/gaia-py-latest/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 1589, in find_element
    response = self._send_message('findElement', 'value', **kwargs)
  File "/Users/mwargers/.virtualenvs/gaia-py-latest/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/Users/mwargers/.virtualenvs/gaia-py-latest/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 715, in _send_message
    self._handle_error(response)
  File "/Users/mwargers/.virtualenvs/gaia-py-latest/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 751, in _handle_error
    raise errors.lookup(status)(message, stacktrace=stacktrace)
TEST-INFO took 87183ms

SUMMARY
-------
passed: 0
failed: 1
todo: 0

I saw this happening too with the old base image. After updating my base image, it didn't happen anymore.
So that means the base image on all the devices in the bitbar lab need to be updated.
(Assignee)

Comment 1

3 years ago
Oh, now I can also reproduce with the latest base image.

Serial: 807fd0eb (State: device)
Build ID               20150715010202
Gaia Revision          c6ef08964711f461a8e6326eae911789d1ec220c
Gaia Date              2015-07-15 00:38:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c95ebeebbc5d
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150715.042028
Firmware Date          Wed Jul 15 04:20:41 EDT 2015
Bootloader             L1TC000118D0

So something is very wrong, see also bug 1184161.
Depends on: 1184161
Summary: Failure in test_dialer.py because base image of device needs to be updated → Failure in test_dialer.py in call_screen.wait_for_outgoing_call
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1184161
(Assignee)

Updated

3 years ago
No longer depends on: 1184161
(Assignee)

Updated

3 years ago
No longer blocks: 1183710
You need to log in before you can comment on or make changes to this bug.