Update automated tests for onyx/splice to include 'hello' channel

VERIFIED FIXED

Status

Content Services Graveyard
Tiles: Ops
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: kthiessen, Assigned: nanj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
From IRC:

[09:46:27] <relud> oyiptong: it occurs to me that testing does not cover this new channel
[09:46:54] <oyiptong> aha hmm
[09:47:14] <oyiptong> there is new information
[09:47:17] <relud> it would be nice if we could get a splice and onyx release that updates the default channels for the geoip_api_test.py and tile_index_crawl.py, but which will only be deployed to the monitor server
[09:48:07] <oyiptong> we want the data in the monitoring script to make sure Access-Control-Allow-Origin is set on the CDN front
[09:48:24] <oyiptong> there is ongoing investigation work there
[09:48:34] <relud> oyiptong: none of the monitoring scripts download anything from the cdn
[09:48:36] <oyiptong> ah
[09:48:38] <oyiptong> just on S3?
[09:48:39] <oyiptong> cool
[09:48:41] <relud> yep
[09:48:49] <oyiptong> that would be easy to do
[09:49:06] <relud> yeah, possibly a good test to have
[09:49:27] <oyiptong> maybe nanj could work on it? it would be a good way to get familiar with onyx/splice
[09:49:28] <relud> perhaps configure the tile_index_crawl.py to download everything except the tile index from the cdn
[09:49:44] <oyiptong> i mean onyx
[09:49:45] <oyiptong> lol
[09:52:45] <kthiessen> relud, oyiptong: I am willing to file a bug to get those tests modified/updated.  Olivier can assign it to Nan if that seems reasonable.
[09:52:58] <oyiptong> awesome
[09:53:07] <relud> kthiessen: that would be great
to clarify:
tile_index_crawl.py is a splice test
geoip_api_test.py is an onyx
also https://github.com/mozilla/onyx/blob/master/onyx/api/v3.py#L14 needs to add support for the new channel
and onyx configuration needs to add support for the new channel

Updated

3 years ago
Blocks: 1183835
Assignee: oyiptong → najiang
Summary: Update automated tests for onyx to include 'hello' channel → Update automated tests for onyx/splice to include 'hello' channel

Comment 2

3 years ago
Commit pushed to master at https://github.com/mozilla/onyx

https://github.com/mozilla/onyx/commit/a23634bf7b30ff52dd20fcb82a1a9ba2d6691f4c
Close Bug 1184208 - Update automated tests for onyx/splice to include 'hello' channel

commit 97a691353bc7b53424b1efd730b76ad0cac62628
Author: Nan Jiang <njiang028@gmail.com>
Date:   Fri Jul 17 13:55:31 2015 -0400

    Add support for the 'hello' channel

Close #29

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

3 years ago
Verified in stage.
Status: RESOLVED → VERIFIED

Updated

3 years ago
Blocks: 1182449

Updated

3 years ago
Duplicate of this bug: 1184330
You need to log in before you can comment on or make changes to this bug.