Closed Bug 1184210 Opened 5 years ago Closed 5 years ago

[Status Bar] 'Pin the Web' icon doesn't always mirror app icon, shows pin graphic

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-master verified)

VERIFIED FIXED
FxOS-S3 (24Jul)
Tracking Status
b2g-master --- verified

People

(Reporter: onelson, Assigned: apastor)

References

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing], [Spark], [systemsfe])

Attachments

(3 files)

Description:
When a user enters an application, they may observe that the 'pin the web' icon on the search bar will now mimic the icon of the current application and list the name of the app in the search. However, the user may observe upon entering certain apps, first open or waking from card view, that the app icon will display the pin graphic again instead of the app.
Looks like this bug created the functionality: bug 1181602
Issue is commonly reproducing in clock and calendar apps, and not within communication apps (dialer, messages, contacts). Though, actual behavior has also been seen within clock as well.

Repro Steps:
1) Update a Flame to 20150715010202
2) Open the Clock app
3) Observe the "Search the Web" bar of the status bar: displays "Clock"
4) Observe the 'pin the web' icon

Actual:
'pin the web' icon displays pin graphic

Expected:
'pin the web' icon mirrors open app icon


Environmental Variables:
-------------------------

Device: Aries 2.5
BuildID: 20150715083340
Gaia: c6ef08964711f461a8e6326eae911789d1ec220c
Gecko: c95ebeebbc5d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
Build ID: 20150715010202
Gaia: c6ef08964711f461a8e6326eae911789d1ec220c
Gecko: c95ebeebbc5d
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
************************

Issue is not present on 2.2 for flame devices
Results: No 'pin the web' icons in status bar

Device: Flame 2.2
BuildID: 20150715002506
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: a5db6d9850f6
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-------------------------


Repro frequency: 3/5
See attached: 
screenshot
logcat [dialer, messages, contacts: expected  |  clock, calendar: actual]
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1181185
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
I don't think this is a duplicate of bug 1181185. I think there is a race condition somewhere, so sometimes is showing the right icon and sometimes is not.

I'll take a look.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → apastor
Attachment #8634612 - Flags: review?(bfrancis)
Comment on attachment 8634612 [details] [review]
[gaia] albertopq:1184210-icon-race-cond > mozilla-b2g:master

Thanks Alberto!
Attachment #8634612 - Flags: review?(bfrancis) → review+
https://github.com/mozilla-b2g/gaia/commit/5f3cfc662bac683438ddd260f4bbd1f55b3b5b9b
Blocks: 1168944
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S3 (24Jul)
No longer blocks: 1168944
Duplicate of this bug: 1181185
This issue is verified fixed on the latest Spark and Flame 2.5 builds.
All default system apps properly display their app icon in the status bar for 'pin the web'

Environmental Variables:
Device: Aries 2.5
BuildID: 20150827170205
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: ca086f9ef8bca2d6cdfa79bfc4c854f56a59859e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150827083151
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: b33eae31bd7188024b54228e0c0345800a65e595
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.