IMAP: Extra ref count on nsImapMailCopyState causes temp file not deleted

VERIFIED FIXED in M11

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: jefft, Assigned: jefft)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
Due to the swapping running url by netlib, setting copy state to imap url can
cause copy listener not release. In turn it causes the temp file not get
deleted. I don't how to better discribe this problem. It's a tough problem.
Enter it here for tracking.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 1

18 years ago
*** Bug 9791 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Jeff's on vacation; moving his M10 bugs to M11
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

18 years ago
David has checked in the fix for me while I was on vacation. Mark it as fixed.

Comment 4

18 years ago
Can I go ahead and mark this verified since it's a bug jeff filed against
himself?

Comment 5

18 years ago
sure, go ahead.

Updated

18 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.