Depth buffer should not be cleared in GL compositor

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: acomminos, Assigned: acomminos)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
apitrace reports the following warning:

> Failed to fast clear depth due to scissor being enabled. Possible 5% performance win if avoided.

I discussed this with :mattwoodrow in person and we agreed that it doesn't make any sense for the GL compositor to clear the depth buffer.
(Assignee)

Comment 1

3 years ago
Created attachment 8634405 [details] [diff] [review]
Disable GL scissor test before clearing.

Talos try push for possible OS X 10.10 regression:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a36de385f031
Attachment #8634405 - Flags: review?(mstange)
(Assignee)

Updated

3 years ago
See Also: → bug 1065256
(Assignee)

Updated

3 years ago
See Also: → bug 1184534
(Assignee)

Comment 2

3 years ago
Comment on attachment 8634405 [details] [diff] [review]
Disable GL scissor test before clearing.

This shouldn't be necessary with the fix for bug 1184534.
Attachment #8634405 - Flags: review?(mstange)
(Assignee)

Comment 3

3 years ago
Closing as wontfix- GLX defaults to a GLX_DEPTH_SIZE of 0, falling back to FBConfigs with larger depth sizes if necessary. If we're getting a depth buffer at all, it's because we couldn't find an FBConfig without one.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.