Closed Bug 1184416 Opened 5 years ago Closed 5 years ago

Statusbar color does not match homescreen rocketbar background

Categories

(Firefox OS Graveyard :: Gaia::System::Status bar, Utility tray, Notification, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.1 ?, b2g-v2.2 ?, b2g-master affected)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- ?
b2g-v2.2 --- ?
b2g-master --- affected

People

(Reporter: kgrandon, Assigned: mikehenrty)

References

Details

(Keywords: polish, regression, Whiteboard: [systemsfe])

Attachments

(1 file)

If you look closely on the homescreen the statusbar background color does not match - it should.
[Blocking Requested - why for this release]: Blocking because it's a visual regression.
blocking-b2g: --- → 2.5?
status-b2g-v2.1: --- → ?
status-b2g-v2.2: --- → ?
Keywords: regression
blocking-b2g: 2.5? → 2.5+
Keywords: polish
Priority: -- → P3
Component: Gaia::System → Gaia::System::Status bar, Utility tray, Notification
Looks like this has been a problem since as far back as bug 1039519. We add a linear-gradient background image to the app chrome, but the homescreen (much like the lockscreen) doesn't need this. I'll take a look here.
Assignee: nobody → mhenretty
Blocks: 1039519
Ah, nevermind. I misunderstood this one. This is talking about the "mini-rocketbar" in vertical home not matching the system statusbar. I have a fix, but it wasn't caused by bug 1039519.
No longer blocks: 1039519
Comment on attachment 8670788 [details] [review]
[gaia] mikehenrty:bug-1184416-match-background-rocketbar > mozilla-b2g:master

Kevin, what do you think?
Attachment #8670788 - Flags: review?(kevingrandon)
Comment on attachment 8670788 [details] [review]
[gaia] mikehenrty:bug-1184416-match-background-rocketbar > mozilla-b2g:master

That was bugging me, thanks for fixing it. So much better now!
Attachment #8670788 - Flags: review?(kevingrandon) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/4973f57cd8f9a62a95f783a24eac32da2bde99fc
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.