Closed Bug 1184424 Opened 7 years ago Closed 7 years ago

[Android]Feedback button still active when page is navigated back

Categories

(Marketplace Graveyard :: Consumer Pages, defect, P2)

Avenir
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: trishul.goel, Assigned: madhukarkrazzyrocker, Mentored)

Details

(Whiteboard: [good first bug])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150714004006

Steps to reproduce:

Navigate to marketplace.firefox.com on Android.
tap menu button and tap Feed back option.
Feedback page opens.
Tap 'back' button and homepage opens, now again tap menu button


Actual results:

When Feedback page opens, the 'Feedback' button in slide over menu is highlighted.
Moving back to home, the 'Feedback' button is still highlighted.


Expected results:

When on home the 'Feedback' button should not be highlighted in slide over menu.
I want to work on this bug.
Sure Madhu. Assigning you to this bug.

For any help you can refer to the documentation at http://marketplace.readthedocs.org/, or ask in #marketplace irc channel.
Assignee: nobody → madhukarkrazzyrocker
Mentor: vaishnav.rd
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [good first bug]
Here is my analysis :
- The issue is not only faced with the Feedback button, but all buttons are actually responding the same. When we press the button, go back and check the toggle menu the previous button is always still active. 
- On desktop header is managed by header.js and for mobile view we have nav bar which is handled in nav.js. 
- In both files updateActiveNode is handling taking care of showing active button, but 
the main issue is that header is refreshed with we press back button while nav is not refreshed when we press back button.

I think we need to make code changes to make sure nav is refreshed when we press back button.

Please tell me if this is the correct approach. If yes, please guide me how do I achieve this else you can suggest if there is any better approach to fix this.
Priority: -- → P2
David/Kevin,

Could you please advice on above?
Flags: needinfo?(kngo)
Flags: needinfo?(ddurst)
Any updates on this?
Good debugging madhukarkrazzyrocker!

The `navigate` event doesn't get triggered when using the back button. In header.js we update the state on `navigate loaded` [1] but in nav.js we only update on `navigate` [2]. So you're right, that should be `navigate loaded` in nav.js.

I think this will cause the menu to close if you had it open and press the back button which I think is fine but if it feels weird we can come up with a solution.

[1] https://github.com/mozilla/fireplace/blob/65a024b449d981e9019f1eabbf2ed4f70491a45a/src/media/js/elements/header.js#L228
[2] https://github.com/mozilla/fireplace/blob/65a024b449d981e9019f1eabbf2ed4f70491a45a/src/media/js/elements/nav.js#L231
Flags: needinfo?(kngo)
Flags: needinfo?(ddurst)
Hi Madhukar, are you still working on this?
Flags: needinfo?(madhukarkrazzyrocker)
Yeah. but I'm facing few errors which are not letting me to start the web server, not letting me to open marketplace. I'll try to start everything from the beginning and fix this bug As soon as possible.
Flags: needinfo?(madhukarkrazzyrocker)
Any progress on this? If this is still unchanged in two weeks, we'll unassign it. (Let us know in channel if you have issues with the environment itself.)
Flags: needinfo?(madhukarkrazzyrocker)
Marketplace UI/UX has been updated a lot by now. I can't reproduce the bug anymore. 

Can you have a look if the bug is still reproducible, Trishul ? 
We may close this, if it is not reproducible anymore!
Flags: needinfo?(trishul.goel)
This is not reproducible in new UI, hence closed.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(trishul.goel)
Flags: needinfo?(madhukarkrazzyrocker)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.