Home button blocks other button in when trying to open zip

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: jhao, Assigned: rakhavan)

Tracking

({dogfood})

unspecified
dogfood

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [bzlite][systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

When I downloaded and tried to open a zip, it can't be opened and I was asked whether to delete it or else. The buttons below were blocked by home button. See the screenshot below.
(Reporter)

Comment 1

3 years ago
Created attachment 8634595 [details]
screenshot.png
(Reporter)

Comment 2

3 years ago
I was dogfooding with Z3C.

Comment 3

3 years ago
Triagr automatic comment: didn't know what to do when triaging.
Hey Michael, Can you please take a look at this one and find a right owner if it isn't you? 

Thanks.
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::Homescreen
Flags: needinfo?(mhenretty)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Flags: needinfo?(mhenretty)
Whiteboard: [bzlite] → [bzlite][systemsfe]
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Homescreen → Gaia::System
Priority: -- → P2
Component: Gaia::System → Gaia::System::System UI
Reza, wanna take a look?
Flags: needinfo?(rakhavan)
(Assignee)

Updated

3 years ago
Assignee: nobody → rakhavan
Flags: needinfo?(rakhavan)
(Assignee)

Comment 7

3 years ago
I'll start on this today most likely.
(Assignee)

Comment 8

3 years ago
I'm working off of gaia/master and I'm unable to reproduce this.

I downloaded a zip file and clicked on the notification from the utility tray and saw the keep-file/delete dialog without the buttons being clipped.

Then I tried from the settings > downloads screen. Where I clicked on the zip file and saw a open/share dialog. When I clicked open, I again saw the keep-file/delete dialog without the buttons being clipped.
Can QA still reproduce?
Keywords: qawanted
No Repro per builds: 

Environmental Variables:
Device: Aries 2.5
BuildID: 20151005111147
Gaia: b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Gecko: 45f01961ecd0ad9a45067f3e08bfb92539042eeb
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULT:
When download a zip (compressed) file as an attachment from email, and then click on the top banner, 
the keep-file/delete dialog buttons were displayed without cropping or clipping as expected. 

Environmental Variables:
Device: Flame 2.5
BuildID: 20151005030238
Gaia: b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Gecko: b56aeea0c4701677ffda6417183caa60d2a6a4a7
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULT:
When download a zip (compressed) file as an attachment from email, and then click on the top banner, 
the keep-file/delete dialog buttons were displayed without cropping or clipping as expected.
QA Whiteboard: [foxfood-triage] → [foxfood-triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Contact: sleedavid
We were able to reproduce this issue on earlier builds but not today.  Resolving WFM but please reopen if it occurs again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [foxfood-triage?] → [foxfood-triage+]
Flags: needinfo?(jmercado)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.