[OS X] Printing from built-in PDF viewer does not work

RESOLVED DUPLICATE of bug 1188752

Status

()

Core
Printing: Output
--
critical
RESOLVED DUPLICATE of bug 1188752
3 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

({regression})

Trunk
Unspecified
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41+ verified, firefox42+ verified, firefox43 verified)

Details

(Reporter)

Description

3 years ago
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Reproducible with latest 41.0a2 and 42.0a1 e10s on/off (both from 2015-07-15)
Affected platform: Mac OS X 10.9.5

Steps to reproduce:
1. Launch Firefox.
2. Load any pdf sample (E.g.: http://fzs.sve-mo.ba/sites/default/files/dokumenti-vijesti/sample.pdf)
3. Print it.

Expected result: PDF is printed.
Actual result: PDF is not printed. Print dialog appears and a successful connection is displayed, but nothing happens.

Additional notes:
1. Printer 'Kyocera ECOSYS P2135dn' is installed in Printers & Scanners System Preferences panel.
2. Browser console output:

‘[Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIPrintSettingsService.defaultPrinterName]"  nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame :: chrome://global/content/browser-content.js :: getPrintSettings :: line 425"  data: no]’ thrown by browser-content.js:436:0
‘TypeError: printSettings is null’ thrown by browser-content.js:500:1

3. Not reproducible with Firefox 40 beta 4 (Build ID: 20150713153304), although the same Browser Console output is displayed. 
4. Unable to reproduce under Windows 8.1 x64, Windows 10 x86 nor Ubuntu 14.04 x86.
5. Regression range:
Last good revision: ce863f9d8864
First bad revision: c319f262ce3e
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ce863f9d8864&tochange=c319f262ce3e

Please note that on above First bad revision, I encountered a quite different behaviour: no printer dialog displayed; “Some printing functionality is not currently available.” message displayed when I attempt to print once more; PDF printing works with e10s disabled. 

Therefore, the issue described in this bug report started to happen with → First bad revision: 3a032d9bd613 
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8445e75f3116&tochange=3a032d9bd613

Comment 1

2 years ago
Yikes! Let's try to get a fix soon.
tracking-firefox41: ? → +
tracking-firefox42: ? → +
I can't reproduce on Linux, FWIW. (In a profile with e10s disabled, I can view the attached PDF and "print" it [to a PDF, using Ubuntu's built-in PDF printer] just fine.)

So, might be mac-only (which matches the reporter's [OS X] assessment in bug summary).

In any case -- the most relevant cset in comment 0's second (more-relevant) regression-range seems to be:
{
 9a9a92d6d78b	Yury Delendik — Bug 1179262 - Remove PlayPreview usage from PDF viewer. r=bz
}

Yury, is it possible that might've broken PDF.js printing?
Flags: needinfo?(ydelendik)
Summary: [OS X] PDF printing does not work → [OS X] Printing from built-in PDF viewer does not work
(In reply to Daniel Holbert [:dholbert] (out 8/5-8/10) from comment #2)
e -- the most relevant cset in comment 0's second (more-relevant)
> regression-range seems to be:
> {
>  9a9a92d6d78b	Yury Delendik — Bug 1179262 - Remove PlayPreview usage from
> PDF viewer. r=bz
> }
> 
> Yury, is it possible that might've broken PDF.js printing?

I don't think it's possible, since the patch above affects only loading using EMBED tag, which is not in STR. To avoid any speculations, let's find the exact commit.
Flags: needinfo?(ydelendik)
Keywords: regressionwindow-wanted
I've worked today on this and got a different regression window (Mac OS X 10.8.5):
Last good revision - 2015-06-19 - 2694ff2ace6a
First bad revision - 2015-06-20 - c319f262ce3e
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2694ff2ace6a&tochange=c319f262ce3e 

Further bisection indicates that the cause for regression was bug 1167235:
Last good revision: d1d45ce7cbf5
First bad revision: eccde665c72a
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d1d45ce7cbf5&tochange=eccde665c72a

However, this issue now no longer reproduces on latest Firefox 41 Beta 5, latest Firefox 42 Aurora, and latest Firefox 43 Nightly. I believe this issue got fixed along with bug 1188752 (which also was a regression from bug 1167235), so I'm going to close it as a duplicate of bug 1188752.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox41: affected → verified
status-firefox42: affected → verified
status-firefox43: --- → verified
Keywords: regressionwindow-wanted → regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1188752
You need to log in before you can comment on or make changes to this bug.