There is no transition to landscape mode when the browser is loading a page

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

({foxfood, polish})

unspecified
ARM
Gonk (Firefox OS)
foxfood, polish

Firefox Tracking Flags

(tracking-b2g:+, b2g-master affected)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
STR
1. Load a webpage
2. While the page is loading, flip the phone horizontally

Results
The browser gets flipped to landscape mode, but no animation occurs. However the animation is correctly displayed if you switch back to portrait mode (even if the webpage is still loading). If you're in a low data coverage area, you can repeat the action multiple times (while loading) and see that every landscape transition is missed and every portrait one is executed. See video: https://goo.gl/qvQxD4

Repro frenquency: 10/10

Build info
Build ID               20150716033647
Gaia Revision          981c61cdeb527fac8f8383c110df0e749eff67ea
Gaia Date              2015-07-16 00:34:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/72835344333f
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150619.224059
Firmware Date          Fri Jun 19 22:41:08 UTC 2015
Bootloader             s1
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]: A missed transition that makes an high-phone look like sluggish, whereas the portrait mode transition is nicely handled.
blocking-b2g: --- → 2.5?
Keywords: foxfood
Whiteboard: [systemsfe]
Not a blocker according to the blocking criteria but important to fix.
blocking-b2g: 2.5? → ---
tracking-b2g: --- → +
Keywords: polish

Comment 3

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.