Selecting text should select its text-decorations (e.g. underline) as well

RESOLVED DUPLICATE of bug 35146

Status

()

RESOLVED DUPLICATE of bug 35146
17 years ago
16 years ago

People

(Reporter: hwaara, Assigned: mjudge)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
If you select some text under windows, it will typically display a selection
with the system's set selection color as background and white as foreground
color for the text.

This foreground color should apply to underlines, overlines, strike-throughs
etc. too.
Are you selecting the entire underlined element, or just part of it?
(Reporter)

Comment 2

17 years ago
Created attachment 63744 [details]
Expected behaviour -- IE5 on Windows
(Reporter)

Comment 3

17 years ago
Created attachment 63745 [details]
Buggy behaviour -- Mozilla on Windows
(Reporter)

Comment 4

17 years ago
Look at the difference in how we select underlines in these screenshots.

This bug is for making all text-decorations obey the selection. BTW, the bug is
maybe pp (Windows-only).
broken on linux too
OS: Windows 98 → All
*** Bug 122457 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
Summary: Selecting text should make text-decorations (e.g. underline) white too → Selecting text should select its text-decorations (e.g. underline) as well
(Assignee)

Comment 7

17 years ago
marking as future.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 8

16 years ago
There's another big problem with Mozilla's behaviour:
If the system's selection color is the same as page's you're viewing background,
it's VERY hard to see the selection in Mozilla.
In IE, the selection color is text's/background's negative.
Comment 8 has nothing to do with this bug.

This bug is a dup.

*** This bug has been marked as a duplicate of 35146 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
I'm sorry!
You need to log in before you can comment on or make changes to this bug.