Crashes when I go to real.com

VERIFIED WORKSFORME

Status

()

Core
Plug-ins
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Michael Schwager, Assigned: av (gone))

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I simply surf to www.real.com.  Shows some of the page, then BOOM.  Happens
every time.

nsWidget::~nsWidget() of toplevel: 43 widgets still exist.
IsPluginFile(/opt/mozilla/plugins/libnullplugin.so) == TRUE
###!!! ASSERTION: frame was not removed from primary frame map beforedestruction
or was readded to map after being removed: '!PL_DHASH_ENTRY_IS_BUSY(entry) ||
entry->frame != aFrame', file nsFrameManager.cpp, line 984
###!!! Break: at file nsFrameManager.cpp, line 984
For * found plugin /opt/mozilla/plugins/libnullplugin.so
LoadPlugin() /opt/mozilla/plugins/libnullplugin.so returned 8b046b8
About to create new ws_info...
About to create new xtbin of 760 X 300 from 0x88c8868...
About to show xtbin(0x893cdc0)...
/opt/mozilla/run-mozilla.sh: line 72: 12549 Segmentation fault      $prog ${1+"$@"}

Comment 1

17 years ago
Reporter: Please remember to always include build ID in bug-reports.
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 2

17 years ago
Testing linux build ID 2002010606 without plugins installed: No crash.
(No crash with plugins installed either.)

Comment 3

17 years ago
Possibly something with SetWindow()? Dunno, just got back, cc:ing Serge

Comment 4

17 years ago
Michael Schwager, have you try any latest nightly builds?
but I cannot reproduce the crash in my 2002-01-04 debug build either.

Comment 5

17 years ago
Michael? Pls respond else this will be marked wfm since no one can repro this 
bug.Thx!

Comment 6

17 years ago
Resolving as WFM. This still works here on a fresh CVS, Linux.

I mailed reporter and asked for build ID etc. and got reply:

From: Michael Schwager <schwager@enteract.com>
To: "R.K.Aa." <dark@c2i.net>
Subject: Re: Regarding bugzilla bug 118476
Message-ID: <10438753.1011316651@[192.168.100.205]>
[]

I'll bet it's related to an X-windows library that became somehow corrupt 
on my machine and was seg faulting Java applets (my Opera wouldn't run Java 
applets).

I don't have time to investigate it further so go ahead and close the bug. 
Thank you for your attention.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.