If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tools to debug font probs in the field

NEW
Assigned to

Status

()

Core
Internationalization
16 years ago
9 years ago

People

(Reporter: kill this account, Assigned: smontagu)

Tracking

({intl})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The best tools to debug Unix/Linux font problems (eg: NS_FONT_DEBUG and/or
PR_LOG) is worthy of a discussion. 

For example, the NS_FONT_DEBUG prints are available in optimized builds
where as PR_LOG is not.

http://www.mozilla.org/projects/nspr/reference/html/prlog.html#25266

 Logging is compiled into the NSPR debug builds; logging is not compiled
 into the NSPR optimized builds.

One of the problems I had prior to adding the NS_FONT_DEBUG macros is
that I would get bugs from users (often with optimized builds) saying the font 
search did something wrong.  Since I could not reproduce the font environment 
I frequently could not reproduce the problem. This made it very hard to debug
and fix these problems.
You can keep PR_LOG there in optimized builds; mailnews and XPCOM both do, and
we build NSPR optimized-with-logging to accomodate them.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 2

16 years ago
Great! That was my biggest concern (I apologize for not being a NSPR expert).

Is there a way to get PR_LogPrint to automatically add the
__FILE__ and __LINE__ number?

Updated

16 years ago
Status: NEW → ASSIGNED

Updated

16 years ago
Keywords: intl

Comment 3

16 years ago
reassign to shanjian
Assignee: ftang → shanjian
Status: ASSIGNED → NEW
Target Milestone: --- → Future

Comment 4

16 years ago
accept. 
Status: NEW → ASSIGNED

Comment 5

13 years ago
shanjian is no longer working on mozilla for 2 years and these bugs are still
here. Mark them won't fix. If you want to reopen it, find a good owner first. 
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 6

13 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 7

13 years ago
Mass Re-assinging Frank Tangs old bugs that he closed won't fix and had to be
re-open. Spam is his fault not my own
Assignee: shanjian → nobody
Status: REOPENED → NEW
Filter on "Nobody_NScomTLD_20080620"
Assignee: nobody → smontagu
QA Contact: ruixu → i18n
You need to log in before you can comment on or make changes to this bug.