Closed Bug 1184864 Opened 7 years ago Closed 7 years ago

[Android] Horizontal scroll on feed/editorial page on android

Categories

(Marketplace Graveyard :: Consumer Pages, defect, P3)

Avenir

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: trishul.goel, Assigned: trishul.goel)

References

Details

(Whiteboard: [ktlo])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150716004006

Steps to reproduce:

1. Goto https://marketplace.firefox.com/feed/editorial/games?src=branded-editorial-element on android mobile.
2. Swipe left


Actual results:

We get a horizontal scroll, distorting mobile layout


Expected results:

There should be no horizontal scroll.
Checked on Firefox for android on Moto G2, happens in portrait as well as landscape mode.
I am able to reproduce it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → dspasovski
Severity: normal → minor
Priority: -- → P3
Attached file Pull Request
Kindly review
Assignee: dspasovski → trishul.goel
Status: NEW → ASSIGNED
Any updates?
Flags: needinfo?(kngo)
Duplicate of this bug: 1222356
Whiteboard: [ktlo]
Trishul -- if you can make those last changes noted in the PR, this will be good to go.
Flags: needinfo?(trishul.goel)
Created new PR
https://github.com/mozilla/fireplace/pull/1596

added overflow:hidden to .feed-landing-header-mobile instead of .feed-landing-header, so that it doesnt regress to desktop :)
Flags: needinfo?(trishul.goel)
Flags: needinfo?(kngo)
Hi, when I submitted the PR all check passed, in addition its just a line of CSS, I fail to understand why the travis check failed ?
Flags: needinfo?(dspasovski)
The test itself is flaky with reasons unrelated to your PR. We can merge the fix and address the test issues separately.
Flags: needinfo?(dspasovski)
PR Merged

https://github.com/mozilla/fireplace/pull/1596
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.