Closed Bug 1184916 Opened 5 years ago Closed 4 years ago

Menuitem "View Page Source" should be disabled in view-source page

Categories

(Firefox :: Untriaged, defect)

42 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox41 --- unaffected
firefox42 --- unaffected
firefox43 --- verified
firefox44 --- verified
firefox-esr38 --- unaffected

People

(Reporter: magicp.jp, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [bugday-20151118])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150716030208

Steps to reproduce:

1) Open view-source page.
2) You can select "View Page Source" menuitem in view-source page.
3) Repeat step 2)


Actual results:

You can repeat "View Page Source", then URL increase like "view-source:view-source:view-source:..."


Expected results:

Menuitem "View Page Source" should be disabled in view-source page.
I confirmed that Firefox 42.0a2 and 43.0a1 works fine with the expected result.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151001142456

CONFIRMED. [testday-20151002]
Attached image Capture.PNG
Can you still reproduce this magicp ?? try updating your browser and let me know,
Looks like relase 41.0.1, beta 42, developer edition 43 and nightly 44 has no such issue.
I am on windows 7

are you on windows 10 ?
(In reply to [:Towkir] Ahmed from comment #4)
> Can you still reproduce this magicp ?? try updating your browser and let me
> know,
> Looks like relase 41.0.1, beta 42, developer edition 43 and nightly 44 has
> no such issue.
> I am on windows 7
> 
> are you on windows 10 ?

Comment 1
> I confirmed that Firefox 42.0a2 and 43.0a1 works fine with the expected result.
No issue.
Yes, windows XP to 10.
which means you face this on firefox release version 41.0.1, right ?
Can you attach a screenshot please ?
(In reply to [:Towkir] Ahmed from comment #6)
> which means you face this on firefox release version 41.0.1, right ?
> Can you attach a screenshot please ?

This issue is in Firefox 42 beta and later version, because view page-source behavior was changed to from version 42 as xhtml (not popup window).
Not sure about what you are talking, on comment 1 you said 42 and 43 are good. again on comment 7 you said 42 and later versions are affected,
btw, I have found 41 and 42 showing a popup window for page source, and later versions are good.

still lets see other win 10 users say.
Blocks: windows-10
I filed this bug in July.

for a month... nobody no responses.

I confirmed bug again. I posted comment 1 because bug was fixed. (version 42 was Aurora, 43 was Nightly)

for a month... other issue was posted.

on comment 7, I don't write "affected". version number was shifted now. I thought new style page source(non-popup) was shifted to new 42 beta. As you wrote, 42 beta still have popup page source.
However, this file was posted about MENUITEM in new page source.

You should file a bug if needed, because showing a popup window is other issue.
Thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Attached image LooksFine.png
Thanks magicp
on 43.0a2 it looks as exactly as you like it. I am attaching a screenshot.
the page source is on a new tab (no pop up) and the "view page source" is disabled. and soon this will be uplifted to the further versions.
Regression
See Also: Bug 1212480 - Regression: "View Page Source" menu item is enabled for view-source pages
QA Whiteboard: [good first verify]
Successfully reproduce the bug on 
Name 	Firefox
Version 	42.0
Build ID 	20151029151421
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0

The fix works for me on 

Name 	Firefox
Version 	43.0b4
Build ID 	20151116155110
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:43.0) Gecko/20100101 Firefox/43.0


Name 	Firefox
Version 	44.0a2
Build ID 	20151118004041
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0
QA Whiteboard: [good first verify] → [good first verify][bugday-20151118]
I have reproduced this bug with Firefox Nightly 42.0a1 (Build ID: 20150717030202) on 
windows 8.1 64-bit with the instructions from comment 0 .

Verified as fixed with Firefox Aurora 44.0a2 (Build ID: 20151118004041)

Mozilla/5.0 (Windows NT 6.3; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Verified as fixed with Firefox Beta 43.0b4 (Build ID: 20151116155110)

Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

As this bug is also verified on Mac OS (Comment 12),I am marking this bug verified.
Status: RESOLVED → VERIFIED
Whiteboard: [bugday-20151118]
You need to log in before you can comment on or make changes to this bug.