Closed Bug 1184963 Opened 5 years ago Closed 5 years ago

Since update to Thunderbird 38.1.0 my address book - add contact and new list are grayed out and not available for use

Categories

(Thunderbird :: Address Book, defect)

38 Branch
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1143812

People

(Reporter: terryg, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Have shut down and restarted program still address book has add contact and new list grayed out or not available for use


Actual results:

Since upgrade to 38.1.0 lost functionality of adding new contact(main concern) and add new list in address book


Expected results:

add new contact and add new list should have been available for use in address book
Add new contact is only not available in GUI. It is available in file - new - address book contact
start thunderbird in safe mode
- http://support.mozillamessaging.com/en-US/kb/safe-mode

Does problem go away?
If it does then please check your addons and tell us which one is causing the problem.
Flags: needinfo?(terryg)
terry, which AB is selected when those buttons are greyed out?
It is currently be enabled for any AB except "All Address Books". This is probably a duplicate of Bug 1143812.
See Also: → 1143812
The personal address book is the one I am using. It doesn't show the collected address book like it did before. If I add contact through the file menu it gives me the option of the two address books
Flags: needinfo?(terryg)
All add-ons were and are disabled. Safe mode made no difference
Terry, can you attach screenshots after blacking out private data as required?
Flags: needinfo?(terryg)
I have photos of screen. I can't copy to this comment area. What email address should I send photos?
Flags: needinfo?(terryg)
You'll want to use "Add an attachment" about one screen down from the top of the bug form
Flags: needinfo?(terryg)
Flags: needinfo?(terryg)
I hope these photos go through OK
Thanks Terry, screenshots explain your problem very well and confirms my suspicion that you have "All address books" selected and are therefore seeing bug 1143812 which we are currently fixing.

You have hidden the directory pane of your AB, that's why you are not seeing which directory/AB is selected, and can't change the selection. (Question: did you hide the AB list deliberately?)

Do this to show the directory pane:

right-click on AB toolbar, then check "Menu bar" to appear
from AB menu bar: View > Layout > directory pane
in the directory pane (AB list) on the left, please click-select any specific AB other than "All address books"
-> the buttons for new contact and new list will be re-enabled.

AB window does not remember your selected AB for the next session (bug 1177706), so currently you might have to do that once per session.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1143812
Thanks Thomas D.,

Directions worked perfectly. I am now back to address book before upgrade.

Some how Glitch or something or upgrade default caused problem because I hadn't changed anything. It changed as soon as I upgraded.

Problem solved.

No it isn't.

Still goes back to original problem when shut down or address book is closed.

once personal AB was selected before upgrade it stayed on personal AB as default now after upgrade id defaults to all AB and will not hold personal AB as before upgrade. I have tried many shut downs but still defaults to all AB. 

Is there a setting somewhere to save settings or save settings on exit?

This is not a duplicate of #1143812

Thanks,
Terry
(In reply to terryg@warwick.net from comment #13)
> Thanks Thomas D.,

Most Welcome.

> Directions worked perfectly. I am now back to address book before upgrade.

Glad to hear that.

> Still goes back to original problem when shut down or address book is closed.
> 
> once personal AB was selected before upgrade it stayed on personal AB as
> default now after upgrade id defaults to all AB and will not hold personal
> AB as before upgrade. I have tried many shut downs but still defaults to all
> AB. 

Iirc, main AB never remembered your last selection but just always defaulted to Personal AB upon session start because Personal AB is the first AB. But I don't have time to verify the old behaviour.

> Is there a setting somewhere to save settings or save settings on exit?

Not yet, but we are working to allow customization of the default AB initially shown, both for main AB window (bug 1177706) and for composition's contacts side bar (bug 1142705).
 
> This is not a duplicate of #1143812

This bug IS a duplicate of bug 1143812 according to your own original description in comment 0. Unexpected default AB is a new aspect which you first introduced in comment 13, and it's covered by bug 1177706 and bug 1142705 respectively. But yes, they are related. :)
Status: RESOLVED → VERIFIED
See Also: 11438121177706
This was not resolved until today when I updated with Version 38.2.0 Everything is working correctly as it did before version 38.1.0
Now if you select personal address book it stays on personal address book and doesn't default to all as with the ver 38.1.0
Thanks for all the help

Later,
Terry
You need to log in before you can comment on or make changes to this bug.