Closed Bug 1184991 Opened 4 years ago Closed 4 years ago

Recipient autocomplete spontaneously changes the addressee email and send it to wrong recipient with saved address or in address book

Categories

(Thunderbird :: Message Compose Window, defect, major)

31 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1152517

People

(Reporter: brousseau3, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.134 Safari/537.36

Steps to reproduce:

I wrote a new message to someone in my address book (used the autocomplete in the address field).  Name/email address was correct.


Actual results:

Upon sending the message, TB changed the recipient to another name/email close to that of the original one.  Noticed it as I (and my wife who also uses TB) started getting replies from those unintended recipients.

Issue appeared in TB 31.5 and later version (I have not tried the latest 31.8 version).  I have reverted to TB 31.3 version until bug is fixed.


Expected results:

Email should have gone to the right recipients.
Severity: normal → major
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Summary: Thunderbird spontaneously changes the addressee email and send it to wrong recipient with address and address book. → Thunderbird spontaneously changes the addressee email and send it to wrong recipient with saved address or in address book.
Benoit, pls look at bug 1152517 of which this is most likely a duplicate. Pls confirm if that applies.
Otherwise there are a few other listed in the see-also field of bug 1152517.

Fixes will mostly land on the newest versions; it's not recommended to remain with outdated versions.
See Also: → 1152517
Summary: Thunderbird spontaneously changes the addressee email and send it to wrong recipient with saved address or in address book. → Recipient autocomplete spontaneously changes the addressee email and send it to wrong recipient with saved address or in address book
(In reply to Thomas D. from comment #1)
> Benoit, pls look at bug 1152517 of which this is most likely a duplicate.
> Pls confirm if that applies.
> Otherwise there are a few other listed in the see-also field of bug 1152517.
> 
> Fixes will mostly land on the newest versions; it's not recommended to
> remain with outdated versions.
Flags: needinfo?(brousseau3)
Hi,

Yes, this seems to be the same bug.  Looking forward to the fix as I won't use any new versions until it is no longer an issue.  Thanks all for producing a great piece of software.

Benoît
Flags: needinfo?(brousseau3)
Thanks for the update
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152517
You need to log in before you can comment on or make changes to this bug.