Characters in URL bar are cut-off

NEW
Unassigned

Status

()

Firefox
Address Bar
2 years ago
2 years ago

People

(Reporter: valentin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8635350 [details]
url_bar_1.png

During the past week I've noticed characters in the URL bar are sometimes cut off, usually by a couple of pixels. This started happening around the same time the new tracking-protection & permissions dropdown was introduced.

From what I can see, it usually cuts off part of the first character in either the scheme, domain name, or even the green cert on bugzilla. See attachments.

- I'm using Gnome-Ubuntu with Firefox Nightly 42.0a1 (2015-07-16)
(Reporter)

Comment 1

2 years ago
Created attachment 8635351 [details]
url_bar_2.png
(Reporter)

Comment 2

2 years ago
Created attachment 8635352 [details]
url_bar_3.png
Is this reproducible? This this always happen for some URLs?
Flags: needinfo?(valentin.gosu)
(Reporter)

Comment 4

2 years ago
Yes, it always happens, and I've just discovered the reason. I have a high res screen, so I set the layout.css.devPixelsPerPx pref to 1.5
Resetting it seems to fix it, but I would still rather it worked.
Flags: needinfo?(valentin.gosu)
Adding Paolo, he has done a lot of work on the identity box lately.

Comment 6

2 years ago
We're using regular margin and padding properties there, although in some cases I've seen in the code that we use values that are a bit off by a small fractional values, to work around bugs.

This, and the fact it happens in the middle of the text too, makes me think this problem might be a font layout bug. To verify whether it's a regression from the identity block changes or not, can you try this with a build made right before and right after bug 1180202 landed?
(Reporter)

Comment 7

2 years ago
(In reply to :Paolo Amadini from comment #6)
> We're using regular margin and padding properties there, although in some
> cases I've seen in the code that we use values that are a bit off by a small
> fractional values, to work around bugs.
> 
> This, and the fact it happens in the middle of the text too, makes me think
> this problem might be a font layout bug. To verify whether it's a regression
> from the identity block changes or not, can you try this with a build made
> right before and right after bug 1180202 landed?

That seems to be the exact point when this bug started occuring (the fx-team merge to mc)
I don't see the bug in rev c9f187c55060 [1] but I do in rev 7ec3e4b2a45f [2]

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux64/1436484218/
[2] http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux64/1436484279/

Thanks!
Created attachment 8686679 [details]
Screenshot of URL area showing cut-off characters

I have a very similar issue, with characters cut off at the bottom in the URL area.  Is this likely to be the same problem, or should I file a new ticket?
You need to log in before you can comment on or make changes to this bug.