Closed Bug 1185143 Opened 5 years ago Closed 5 years ago

[Contacts] Backing out of selecting an emergency/ICE contact brings user to blank page in Contacts.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S6 (04Sep)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: NicholasN, Assigned: mancas)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark][NG Gaia Contacts][patch][2.5-aries-test-run-2])

Attachments

(2 files)

Attached file logcat_ICE.txt
Description:
The user goes into the settings page of Contacts, selects "Set ICE contacts", goes to select a contact for ICE Contact 1 or 2, then taps the X on the contact list. Then they tap the back arrow on the "ICE Contacts" page which brings them to a plain white screen. From here their only option is to enter card view and close the app.


Repro Steps:
1) Update a Aries to 20150717125848
2) Go to Contacts and tap the cog icon in the upper right.
3) Tap "Set ICE Contacts", slide one of the sliders for ICE contact 1 or 2, and tap "Select a contact."
4) Press X on the contacts list, then tap the back arrow on ICE Contacts.


Actual:
User is brought to a blank white screen in Contacts.


Expected:
User is brought to the main contacts page.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150717125848
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 15155971639c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 5/5
See attached: video clip, logcat
Issue also occurs on Flame 2.5, but not on Flame 2.2

Flame 2.5

Actual:
User is brought to a blank white screen in Contacts.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150717010206
Gaia: 77bc0d940bde2a5d2d4dfadfcccc6d8d77456d36
Gecko: 8d262d1d0ae5
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Flame 2.2

Actual Result:

User is brought to the main contacts page after backing out of contacts setting page.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150717002506
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 418b2388edb0
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Regression causing a broken user flow.

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
Comms triage: Regression breaking the UI.
blocking-b2g: 2.5? → 2.5+
This issues seems to have been caused by the changes for Bug 1177662.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150710014834
Gaia: c77dffdbd9f6f53936dc75ac34987df50c136c38
Gecko: 1d172c4a0057
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150710025832
Gaia: 78995dc5e4c1378788ae0494f999d3cdf5b946d2
Gecko: b774d59dd4c9
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: c77dffdbd9f6f53936dc75ac34987df50c136c38
Gecko: b774d59dd4c9

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 78995dc5e4c1378788ae0494f999d3cdf5b946d2
Gecko: 1d172c4a0057

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/c77dffdbd9f6f53936dc75ac34987df50c136c38...78995dc5e4c1378788ae0494f999d3cdf5b946d2
Flags: needinfo?(ktucker)
Manuel, can you take a look at this please? This might have been caused by the landing for bug 1177662.
Blocks: 1177662
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][NGA Contacts]
Target Milestone: --- → FxOS-S3 (24Jul)
Manu, can you have a look, please?
Flags: needinfo?(b.mcb)
Whiteboard: [2.5-Daily-Testing][Spark][NGA Contacts] → [2.5-Daily-Testing][Spark][NG Gaia Contacts]
Assignee: nobody → b.mcb
Status: NEW → ASSIGNED
Flags: needinfo?(b.mcb)
Target Milestone: FxOS-S3 (24Jul) → FxOS-S4 (07Aug)
Comment on attachment 8639169 [details] [review]
[gaia] mancas:bug1185143 > mozilla-b2g:master

Hey Borja, can you review the patch? The problem was a listener that it wasn't removed properly when changing the header action
Attachment #8639169 - Flags: review?(borja.bugzilla)
Whiteboard: [2.5-Daily-Testing][Spark][NG Gaia Contacts] → [2.5-Daily-Testing][Spark][NG Gaia Contacts][patch]
Attachment #8639169 - Flags: review?(borja.bugzilla) → review+
Target Milestone: FxOS-S4 (07Aug) → FxOS-S5 (21Aug)
Duplicate of this bug: 1191719
Target Milestone: FxOS-S5 (21Aug) → FxOS-S6 (04Sep)
Manuel, could you restart treeherder to see if your PR passes the tests so we can merge it, please? Thanks!
Flags: needinfo?(b.mcb)
Whiteboard: [2.5-Daily-Testing][Spark][NG Gaia Contacts][patch] → [2.5-Daily-Testing][Spark][NG Gaia Contacts][patch][2.5-aries-test-run-2]
Landed in master: https://github.com/mozilla-b2g/gaia/commit/76866eb1e9b1c0d6ebd2b04e783631efdc6c789e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(b.mcb)
Resolution: --- → FIXED
Tested in latest master build and working fine, thanks Manu!

Environmental Variables (9/2):
flame master (2.5 version)
Build ID: 20150902054404
Gecko: 288dfa7
Gaia: e9d7c4e
Platform version: 43.0a1
This issue is verified fixed on the latest Flame and Aries 2.5 builds.
The user is properly returned to the Contact Settings page after backing out of ICE contacts screen.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150904030224
Gaia: d7385b79e68d4ad662cacf810506e9ee53345d23
Gecko: 7f987c38bd3e5ac9a834981e85378bdb02338e9d
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20150904191331
Gaia: 03be7d8918bed58c92a40bba211bbbc97a0e516a
Gecko: 538ccb262ec9f022b198d5fbe57a9c99c7eee9b7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.