Transition for closing fullscreen is sometimes too long

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: pawel, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150717030202

Steps to reproduce:

Hi I would like say about new feature in nightly.
full screen watch movie for example in youtube last to long.
I open movie about 1 sec. but close this move is about 4 sec.I think is too long about 3 sek.

Please Team Mozilla designer change time close full screen.I think 1 sec is good.
It's by "design".
You can disable or control it with these 2 preferences in about:config
- full-screen-api.transition-duration.enter
- full-screen-api.transition-duration.leave
Blocks: 1160014
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(In reply to Virtual_ManPL [:Virtual] from comment #1)
> It's by "design".

No, it's not. The design is ~1s for both entering and leaving fullscreen. Leaving fullscreen should not be longer than entering, since that doesn't make sense.

Could you provide detailed steps to reproduce? e.g. how do you close fullscreen? via escape key, F11 key, the fullscreen button provided by the website, or close the window with Ctrl+W?
Status: VERIFIED → REOPENED
Ever confirmed: true
Flags: needinfo?(kolor33)
Resolution: INVALID → ---
Summary: Full screen → Transition for closing fullscreen is sometimes too long
(Reporter)

Comment 3

3 years ago
Yes exactly .I use button ESC and double click of my mouse on screen.

Time open and close full screen should be the same .How fast nightly can .It the best option .Doesn't waist my time to wait.
Flags: needinfo?(kolor33)
By design I meant that now Firefox slow down transition when it's going fullscreen due to animation, where before it was fast, as it was without one.

So pawel if really you want
(In reply to pawel from comment #3)
> How fast nightly can .It the best option .Doesn't waist my time to wait.
just do what I wrote in Comment 1
(Reporter)

Comment 5

3 years ago
Yes I can .But if you release Stable Nightly people will be complain .Button ESC from full screen on my fast computer Intel® Core™ i7 last about 5 sek ..Too long.
Hello All,

I can not reproduce this issue on the newest Firefox build 43.0.1:

Name 	Firefox
Version 	43.0.1
Build ID 	20151216175450
Update History 	
Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

Is this still an issue for you all?
Flags: needinfo?(kolor33)
(Reporter)

Comment 7

2 years ago
46 works good.
Flags: needinfo?(kolor33)
Perfect. I will now close this bug. If it starts to happen again please reopen!
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.