open preferences tab next to the current tab

RESOLVED DUPLICATE of bug 1208222

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 1208222
3 years ago
2 years ago

People

(Reporter: tarek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Firefox should open the prefs tab next to the current tab.

For example, when I open the prefs to grab a password for a web site I am currently browsing, it's quite annoying to have the prefs tab opened as the last tab because it involves going back and forth, and sometimes losing the current tab location.

Comment 1

3 years ago
I'd love to work on this bug if someone can help me out with what part of the source code is involved here...
Flags: needinfo?(tarek)
(Reporter)

Comment 2

3 years ago
I can try to ping some people :) thx
Flags: needinfo?(tarek)
(Reporter)

Comment 3

2 years ago
Hey Gijs, what do you think about this change ?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 4

2 years ago
To grab a password you can right click an inputbox (username or password) and use the "Fill Login" or "Fill Password" context menu to find a login you need.

I talked about this with Jared, and we think that to avoid breaking people who depend on the current behaviour, and to have a confusing "sometimes this, sometimes the other" behaviour if the tab is already open (when we'll switch-to-tab), we should middle-ground this by allowing middle-click (and logically also ctrl-click on windows/linux and cmd-click on OSX) to open these items in the adjacent tab. This is analogue to the solution that got explored in bug 528005 for the 'new tab' button, and also what was suggested in bug 1208222 which has a bit more discussion, so I'm duping this there.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1208222
You need to log in before you can comment on or make changes to this bug.