NFC Tag raw APDU exchange support

RESOLVED INVALID

Status

Firefox OS
NFC
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Maxime C., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Try to exchange raw APDU with a tag, there is no such functionality in current implementation.


Actual results:

Impossibility to communicate with RFID / NFC tags outside NDEF read/write use case.


Expected results:

In my opinion we should be able to exchange raw APDU with a tag. Supporting only NDEF read/write on a NFC tag is putting an unnecessary limitation on the technology.
I know this subject already raised up on few blog comments and the answer was 'why should we?' without a proper answer to this question as far as I know.
Most NFC Device are using ISO 14443 (Type A / B and FeliCa variant) for NFC Tag communication, this related to NFC Tag Type list. As you know this standard wasn't created by NFC Forum but exists about 20 years now (created in 1994, approved by ISO Committee in 1997). This makes NDEF highly used by end-user and web community because of good NFC Forum communication, but represents in reality only a small percent of the billions RFID chips used in the world today, and which can perfectly communicate with NFC Devices. I believe transport, access control, vending and identity industries (including governments as passports and most recent Citizen cards of several countries are using a ISO14443 Type A chip and ISO7816 APDU) would have huge interest in this capability.
We already support ISO-DEP on FirefoxOS.

See https://github.com/mozilla-b2g/gaia/tree/master/dev_apps/nfc-api-test for example.
(Reporter)

Comment 2

3 years ago
Oh indeed, I didn't found it whereas I actively searched for it...
Sorry for the noise and thanks for the link, that's good new!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.