bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Hardware acceleration may cause message compose window to lag severely (in unknown circumstances)

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
3 years ago
6 months ago

People

(Reporter: Rob, Unassigned)

Tracking

(Blocks: 1 bug, {perf})

38 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

3 years ago
Hi,

I'm finding that my message (mail) composition window lags behind severely to the point of unusability since the last update ('automatic' update in the Release channel, to 38.1.0).

Apart from the slowness/lag, it seems that the UI is always at least 1 character behind, so it can remain sitting there not showing the last input, until I hit backspace and then instead of showing backspace, it shows the last character, (which has already been removed by the backspace) etc. Very disconcerting. It makes Thunderbird virtually unusable for more than the occasional very short email.

I've searched for similar reports but found none.

I have the following addons:
- Display Mail User Agent 1.7.0
- ImportExportTools 3.2.1
- Lightning 4.0.1
- Provider for Google Calendar 1.0.4
- Remove Duplicate Messages 0.1.14
- SmtpSelect 1.2.1

Please let me know what I can do to help troubleshoot this (or confirm as a bug/incompatibility)?
(Reporter)

Comment 1

3 years ago
2 more remarks re. the add-ons: 
- Lightning has been installed forever and a day on this pc and syncs with two Google Calendars over CalDav
- Provider for Google Calendar: I tried to just disable this (since I don't think it's actually used, since I use CalDAV now) and that didn't matter
(Reporter)

Comment 2

3 years ago
Additionally, I noticed that (on a completely idle pc, except from task manager and my message window) typing in a message can cause thunderbird to experience cpu usage of up to 2%, while keeping backspace held down to re-erase the complete message causes the cpu usage to take 5-10% of cpu with a spike of 37%... seems rather steep.

Comment 3

3 years ago
Calendar has been giving some people problems, especially such things as recurring events/birthday calendars. Do you have either of these?
Flags: needinfo?(rob.smeets)

Updated

3 years ago
Keywords: perf
(Reporter)

Comment 4

3 years ago
Hi Wayne,

I have many recurring events, but it seems to be rather related to input boxes (I experience this in all thunderbird input boxes).

I tried 'turning off' the two synced calendars (by clearing the checkbox next to them in the calendar window) and then restarting thunderbird; and I still have the text input lag.

If you think just turning off the checkboxes like I did is not sufficient to disable the calendar, please let me know and I'll try to disable the calendar more thoroughly.

On the issue itself: My best indication whether I have this issue going on (since the sluggishness in typing is not always that easily quantifyable - you just feel it): just type a long sentence, hold the backspace key to erase part, and stop holding it. The cursor goes back, pauses, and goes back one more character after I've released the backspace key. Plus it's difficult to predict where the cursor will stop (while I'm trained to more or less predict how long I have to hold the backspace key in a text box behaving normally).

I've seen this in all input boxes in Thunderbird, but don't see it in other programs (like Chrome where I'm currently writing this text)
Flags: needinfo?(rob.smeets)

Comment 5

3 years ago
(In reply to Rob from comment #4)
> Hi Wayne,
> 
> I have many recurring events, but it seems to be rather related to input
> boxes (I experience this in all thunderbird input boxes).
> 
> I tried 'turning off' the two synced calendars (by clearing the checkbox
> next to them in the calendar window) and then restarting thunderbird; and I
> still have the text input lag.

you mean the two caldav calendars?
And this occurs with Provider for Google disabled and the two calendars, correct?


> If you think just turning off the checkboxes like I did is not sufficient to
> disable the calendar, please let me know and I'll try to disable the
> calendar more thoroughly.

What other calendars do you have?
Had you previously been running version 38.0.1 and not seen this problem?
Does problem also occur when running with  *Windows'* safe mode with networking enabled?
- win7 http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7
Flags: needinfo?(rob.smeets)
(Reporter)

Comment 6

3 years ago
- many recurring events in the two caldav calendars, indeed
- I get the lag even with provider for google disabled (but since I use caldav only it shouldn't be that anyway); and I get it even with the checkboxes for the two calendars 'unchecked' (but I think that flag only governs whether the calendar is displayed or not, since I also get reminders when the calendars are unchecked). 

If there is another way to disable the calendars totally I'm willing to try but I'd prefer not to have to set them up again (passwords and all that - one of the calendars is my wife's)

I don't have other calendars, just the two caldav's; and the problem turned up with the (automatic) update to 38.0.1.

I'll get back to you on the Windows safe mode, I'm at work atm.
I have exactly the same problem, and I think it started with upgrading to 38.1.0. The echoing of the typed characters in the message composing window is often one character behind, but not always.

This is on Windows 7 32-bit.

I have three Google calendars via CalDAV, and they contain recurring events.
(Reporter)

Comment 8

3 years ago
Thanks for confirming, you describe it better than I could.
Flags: needinfo?(rob.smeets)

Updated

3 years ago
Component: Message Compose Window → Dialogs
Product: Thunderbird → Calendar
Summary: message compose window lags severely → message compose window lags severely with caldav calendar recurring events
Whiteboard: [dupeme]
Version: 38 → Lightning 4.0.0.1
(Reporter)

Comment 9

3 years ago
Hi Wayne,

are you sure that Lightning is the problem? I'd like to test that by disabling Lightning in some way, but I just don't know how to really disable it without losing all my connection info...
I also saw the symptom after deinstalling Lightning.

@Rob: Uninstalling Lightning and re-installing it is not a problem, I had all my accounts again available after re-installing.
(Reporter)

Comment 11

3 years ago
Hey guys,

I can confirm this still exists after uninstalling Lightning.

The mail UI just lags in text input boxes (this is an elderly pc but I don't see this lagging in any other software)

Now I'm crossing my fingers I won't need to re-setup lightning all over again :)
(Reporter)

Comment 12

3 years ago
Also, I now remembered to test in windows safe mode WITH networking: Indeed, the problem does not exist there. (also, thunderbird starts up SOOOOO fast there... incredible)

After restarting, the problem came back, then I reinstalled lightning (which luckily still remembered its settings). The problem remains, of course, with lightning installed and enabled.
(Reporter)

Comment 13

3 years ago
After a (silent? I didn't notice it) update of Thunderbird to 38.2.0, the issue seems gone. I do wonder what this was due to, however... The release notes https://www.mozilla.org/en-US/thunderbird/38.2.0/releasenotes/ mention hardware acceleration being turned off - any ideas how it can be turned on again to see whether this is what caused the behaviour?
(Reporter)

Comment 14

3 years ago
(In reply to Rob from comment #13)
> After a (silent? I didn't notice it) update of Thunderbird to 38.2.0, the
> issue seems gone. I do wonder what this was due to, however... The release
> notes https://www.mozilla.org/en-US/thunderbird/38.2.0/releasenotes/ mention
> hardware acceleration being turned off - any ideas how it can be turned on
> again to see whether this is what caused the behaviour?

Found the switch for Hardware Accelerations, turned it on, restarted thunderbird - lag was back. So this was the culprit.
(Reporter)

Updated

3 years ago
Component: Dialogs → Message Compose Window
Product: Calendar → Thunderbird
Summary: message compose window lags severely with caldav calendar recurring events → Hardware acceleration may cause message compose window to lag severely (in unknown circumstances)
Version: Lightning 4.0.0.1 → 38

Updated

3 years ago
Blocks: 1195947
(In reply to Rob from comment #13)
> After a (silent? I didn't notice it) update of Thunderbird to 38.2.0, the
> issue seems gone. I do wonder what this was due to, however... The release
> notes https://www.mozilla.org/en-US/thunderbird/38.2.0/releasenotes/ mention
> hardware acceleration being turned off - any ideas how it can be turned on
> again to see whether this is what caused the behaviour?

Same observations here: After upgrade to 38.2.0 the issue is gone. Explicitly switching on hardware acceleration brings it back.

I now remember that I had a very similar issue with Chrome on the same laptop (ThinkPad T500 with ATI Mobility Radeon HD 3650 graphics card):

https://code.google.com/p/chromium/issues/detail?id=402134

Comment 16

2 years ago
Rob, I wonder to what extent, if any, your performance issue may haved changed with HWA ENABLED if you use Thunderbird 45?

And also with Thunderbird 48 (where recycled/cached compose window has been removed) available from http://archive.mozilla.org/pub/thunderbird/nightly/latest-comm-aurora/thunderbird-48.0a2.en-US.win32.installer.exe ?
Flags: needinfo?(rob.smeets)
(Reporter)

Comment 17

2 years ago
Hi Wayne, I switched to a new pc and a new version of Windows (W10).

I tried to turn hardware accelleration on a while ago, but I experienced screen redraw issues (where sometimes, the window did not redraw completely when switching windows). I turned the HWA off again and the issues were gone.

So yes, I still have issues, but not the same anymore :)
Flags: needinfo?(rob.smeets)

Comment 18

2 years ago
One more test please - do you still have problems using beta version from http://www.mozilla.org/en-US/thunderbird/channel/ ?
(graphics fixed many bugs since versoin 45, and several people are reporting good results with beta)
Flags: needinfo?(rob.smeets)
(Reporter)

Comment 19

8 months ago
Wayne, sorry I didn't see this question.
I just switched on HWA and everything seems to be OK. I'll keep it on for a while now, we'll see how it goes.
Flags: needinfo?(rob.smeets)

Comment 20

7 months ago
Assuming you've had no problems, so closing. If that is incorrect please update the bug
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

6 months ago
(In reply to Wayne Mery (:wsmwk) from comment #20)
> Assuming you've had no problems, so closing. If that is incorrect please
> update the bug

Yes Wayne, I haven't had to switch it off again. Case closed for my part.
You need to log in before you can comment on or make changes to this bug.