Unable to enable Flash player at specific site

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: bert f., Unassigned)

Tracking

39 Branch
Unspecified
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

450.50 KB, application/msword
Details
(Reporter)

Description

2 years ago
Created attachment 8635734 [details]
Flash plugin.doc

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

I had Flash Player installed and Flash blocker installed. I usually clicked the allow Flash Player to run on a website by website basis. I decided to select the always allow Flash Player to run for the www.cnn.com website. I got tired of the Flash ads playing and tried to return to the 'click to play Flash' feature.


Actual results:

Now I always get "This plugin is disabled" and "Manage plugins..." over Flash player content. I am unable to get any Flash content to play on this website (manage plugins bring up the plugins control panel but there is nothing that would appear to allow me to watch Flash).


Expected results:

I expected to be able to switch between allow Flash or require click to run Flash on a website by website basis.

Firefox version 39.0
Flash Player version 18.0.0.209
Flash blocker version 4.20.13.1-signed
Component: Untriaged → Plug-ins
OS: Unspecified → Windows 7
Product: Firefox → Core
Hi bert f.,

Please try to reproduce this error in the newest version of Firefox (42).
Flags: needinfo?(xmail)

Comment 2

2 years ago
This exact problem occurs with Firefox version 42.0
Hi Bert,

Thanks for following-up. Can you provide precise numbered steps to reproduce so I can accurately try and recreate the issue? It would be greatly appreciated!

Comment 4

2 years ago
I have Shockwave Flash installed (20.0 r0). I also have Flash Block installed. I was prompted by Flash Block to "Allow Now or Allow and Remember" after clicking on an "Activate Flash" for a video on cnn.com. I clicked "Allow and Remember". After a while all the ads on cnn.com got annoying and I wanted to revert back to "Allow Now or Remember" on cnn.com but that query is not available once you click "Allow and Remember" at a website. I don't recall the exact steps, but I found a configuration screen for Flash Block and removed the cnn.com website from the list of "Allow and Remember" websites.
Ever since, I can't watch cnn.com videos because the "Activate Flash" button instead reads "This plugin is disabled" and "Manage plugins..." over Flash player content, Manage Plugins does not allow me to do anything.

Comment 5

2 years ago
Hello Bert, thanks for providing requested info. I tested this issue with Shockwave Flash 22.0 r0 and I was able to revert to "Allow" option after selecting "Allow Now or Remember" option. Do you get option of "Block Plugin" and "Continue Allowing" options when you click on the Flash plugin icon. You can also explore some more options by clicking the "Show site information" button (next to Flash plugin button).

I would really request you to retest this with the updated Flash plugin and current release of Firefox. Please let us know your finding.

Comment 6

2 years ago
Version R22.0 is not available for Flash. I'm using Flash 21 and tried to update and received R21 is up to date. Still getting same error when I try to run a video at cnn.com I will check out site information you suggested and respond later.

Comment 7

2 years ago
I was not able to find "Show Site Information", but I right-clicked on the video 'window' and selected "view page info". Under the page info pop-up I selected "Permissions". Under "Activate Plugins" I selected "Allow" for Flash plugin. I am now able to selectively watch videos on the cnn.com website using the "activate Flash" prompt.
Thank you for your assistance in getting this feature to work.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(xmail)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.