Call log not connected to contacts without the +1 prefix

RESOLVED DUPLICATE of bug 971350

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 971350
3 years ago
3 years ago

People

(Reporter: jryans, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

STR

1. Receive call from contact not on phone
2. Import contacts from Gmail

ER

Previous call log entries should be replaced with contact names if there is a phone number match.

AR

Call log remains numbers only
(Reporter)

Updated

3 years ago
Component: Gaia::Feedback → Gaia::Dialer
It sounds like a regression. QA wanted for a branch check.
Keywords: qawanted
I cannot reproduce this issue. The unknown number that was displayed before importing becomes the contact's name after importing from gmail.

NI reporter to provide more info such as build ID, reproduction rate, and perhaps a video demonstrating the issue.

Tested on:
Device: Flame (full flashed 319MB KK)
BuildID: 20150721010202
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: 3a4bfa5d2d02
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Aries (dogfood debug build)
BuildID: 20150721153949
Gaia: 805cf546729ba742bf23febda52970fcb35c0e8f
Gecko: 512c7e8f0030
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(ktucker)
Flags: needinfo?(jryans)
I also spent some time attempting to reproduce this issue with no success on the same builds Pi Wei used in comment 2.
Flags: needinfo?(ktucker)
(Reporter)

Comment 4

3 years ago
Here is my device info:

Build ID               20150707033152
Gaia Revision          e6506d68e01489b57616f8b74e8773f938ce62b3
Gaia Date              2015-07-06 18:14:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e271ef4c49ae
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150619.224059
Firmware Date          Fri Jun 19 22:41:08 UTC 2015
Bootloader             s1

I think I may have spotted the cause.

* I have a T-Mobile (US) SIM card
* In the call log, numbers show up as +12342342345
* In contacts, number show as (234) 234-2345

So, the contacts don't have the +1 prefix.  If I manually add a "1" prefix to a contact's number, then the call log is able to match it successfully.

This may be a dupe, but I wasn't sure which bug it was precisely.
Flags: needinfo?(jryans)
Summary: Call log not connected to contacts after import → Call log not connected to contacts without the +1 prefix
(Reporter)

Updated

3 years ago
Keywords: dogfood → foxfood
Like you inferred, we have 2 issues here:
1. T-Mobile always shows the 1 at the beginning of the phone number. The dialer team already investigated it 9 months ago, we can't do anything about it.
2. We don't match correctly the contacts if they don't have an international prefix in Contacts, but they do in Dialer. Let's track that in bug 971350.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 971350
You need to log in before you can comment on or make changes to this bug.