Manifestations of copyrastic idiocy should never be supported by Mozilla Foundation

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: heaven-seven, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0.4 Waterfox/36.0.4
Build ID: 20150326192109

Steps to reproduce:

Installed clean Firefox


Actual results:

Third-party bloatware "primetime content decryption module provided by abdolbe..." implementing copyrastic idiocy concepts is integrated into FF and enabled by default.


Expected results:

The FF should be clean, no bloatware or malware integrated, any manifestations of copyrastic idiocy such as DeRMo - unsupported.

Comment 1

3 years ago
See
Bug 1012219
https://blog.mozilla.org/blog/2014/05/14/drm-and-the-challenge-of-serving-users/
https://blog.mozilla.org/blog/2015/05/12/update-on-digital-rights-management-and-firefox/

1. There's an EME-free Windows version.
http://download.cdn.mozilla.net/pub/firefox/releases/latest/win32-EME-free/

2. It's possible to configure preferences prior to updating or installing so that the plug-in isn't downloaded in the first place (media.eme.enabled = false).
http://kb.mozillazine.org/Locking_preferences
http://kb.mozillazine.org/User.js_file

3. It's possible to disable the feature after updating or installing. This deletes all related files and doesn't download them automatically again.
https://support.mozilla.org/kb/enable-drm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
The default variant of FF should be copyrastic-idiocy-free. Those, who need that s-h-i-t, should download the EME-supporting version and configure their preferences. 
Copyrastic idiocy cause troubles, and the troubles must affect on those who are infected by copyrastic idiocy, not on people who are free of it.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

3 years ago
The reason the feature exists and is on by default is explained in the aforementioned blog posts. Bugzilla isn't the place for advocacy; refer to the aforementioned bug 1012219, comment 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.