In mail module, selecting menu messages/modify_as_new_message changes character set from utf8 to western

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: andr55, Unassigned, NeedInfo)

Tracking

SeaMonkey 2.33 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1
Build ID: 20150321194732

Steps to reproduce:

1) select a message with utf8 character set encoding
2) select menu messages/modify_like_a_new_message
3) the new message displays as western character set.
e.g., all accented characters display as 2 (very different) characters 
4) Changing the character set of the new message to utf8 doesn't convert incorrectly displayed characters back to the original utf8.


Actual results:

Errors due to the conversion have to be corrected character by character.


Expected results:

1) The original character set should have been retained.
2) Even if the wrong character set is assigned to the new email, correcting it should reconvert the message to the original character set.

Comment 1

3 years ago
@reporter:
Please send such an e-mail to me so that I can do my own test.
Flags: needinfo?(andr55)
(Reporter)

Comment 2

3 years ago
Sorry it must have been a temporary glitch.
Since posting this I've restarted Mozilla numerous times and now the problem no longer occurs, although it did still occur after at least one restart.
(No, I don't use the quick start option.)
Before it only occurred when modifying non-html messages.
BTW, I restart Mozilla (Seamonkey) often to clear swap memory, since it leaves a lot of old data there.

Closeing as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.