Icon of first crashed tab (e10s) renders outside of tab handle

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: ato, Assigned: mossop)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10sm8+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
When a tab crashes in multi-process Firefox (e10s), the icon of the first crashed tab renders outside of the tab handle.

I do not have any reliable way to reproduce this.
(Reporter)

Comment 1

3 years ago
Created attachment 8636051 [details]
Screen Shot 2015-07-19 at 15.37.54.png

Please see the attached screenshot.
ato, thanks for the report. We'll need further information; are you running with any addons?  If so can you attempt to reproduce this with those addons disabled.  https://addons.mozilla.org/en-US/firefox/addon/nightly-tester-tools/ addon has a crash trigger.

Also, what OS is this reported against?
Flags: needinfo?(ato)
(Reporter)

Comment 3

3 years ago
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #2)
> are you running with any addons?  If so can you attempt to reproduce this with those addons disabled.

I do have an addon to hide the tab bar, which might affect this.

> https://addons.mozilla.org/en-US/firefox/addon/nightly-tester-tools/ addon
> has a crash trigger.

Unfortunately I can’t get that add-on to crash just a single e10s process.  Is there a way to target a single tab/browser?

> Also, what OS is this reported against?

Mac OS X 10.10.4
Flags: needinfo?(ato)
Assignee: nobody → dtownsend
tracking-e10s: --- → m8+
(Assignee)

Comment 4

3 years ago
(In reply to Andreas Tolfsen (:ato) from comment #3)
> (In reply to [:tracy] Tracy Walker - QA Mentor from comment #2)
> > are you running with any addons?  If so can you attempt to reproduce this with those addons disabled.
> 
> I do have an addon to hide the tab bar, which might affect this.

What add-on is that? I can't reproduce this on a clean profile.
Flags: needinfo?(ato)
(Reporter)

Comment 5

3 years ago
(In reply to Dave Townsend [:mossop] from comment #4)
> What add-on is that? I can't reproduce this on a clean profile.

Well that's the problem, I can't reproduce this at all because I've found no way to induce an e10s content process crash.

The addons I had enabled were:

  * Prevent Tab Overflow
  * Hide Tab Bar With One Tab
  * The Fox, Only Better
Flags: needinfo?(ato)
(Reporter)

Comment 6

3 years ago
I found a way to crash an e10s browser process, and it was quite simple: Just kill the process using `kill -9` or similar.

However, killing the first content process did not reproduce the issue with the icon appearing outside the tab boundaries.  For this reason, since we cannot find a way to reproduce it, I will close this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
For future reference, the following add-ons can be used to crash the content process:

https://github.com/luser/crashme
https://addons.mozilla.org/en-US/firefox/addon/tab-crasher/
You need to log in before you can comment on or make changes to this bug.