Closed Bug 1185720 Opened 5 years ago Closed 5 years ago

lockscreen doesn't require passcode (PIN) right after phone boot

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1185096

People

(Reporter: dbaron, Unassigned)

Details

(Keywords: regression)

I believe this is a regression, though I'm not 100% sure.

The lock screen doesn't actually require the passcode right after the phone boots anymore; I can use the phone without entering the lockscreen passcode.

Steps to reproduce:
 1. in Settings, go to Screen Lock and enable both "Lock Screen" and "Passcode Lock" (and have Require passcode: immediately).

 2. Short press the power button twice, swipe to unlock, and observe that the code is required

 3. Long-press the power button and choose Restart

 4. watch the phone boot, and once the lockscreen shows (and before the display turns off!), swipe right to unlock

Actual results:
 4. the phone just unlocks

Expected results:
 4. I should have to enter a PIN, just like I would if the phone hadn't just booted
I observed this in both of the following gaia revisions:
938375d0abafd92d78b3913db1735e49f46a6598 (a few weeks ago)
a47e0c58dd1340a17be7cc96ccd90fcad15a922b (today)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1185096
You need to log in before you can comment on or make changes to this bug.