Closed Bug 1185793 Opened 5 years ago Closed 4 years ago

5,800 instances of "No inner window available!" emitted from dom/base/nsGlobalWindow.cpp during linux64 debug testing

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: erahm, Assigned: khuey)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1182316 +++

This is a regression caused by bug 1182316. |./mach mochitest dom/base/test/test_bug1091883.html| reproduces easily (and quickly).

> 5818 [NNNNN] WARNING: No inner window available!: file dom/base/nsGlobalWindow.cpp, line 3782

This warning [1] shows up in the following test suites:

> mozilla-central_ubuntu64_vm-debug_test-mochitest-3-bm51-tests1-linux64-build21.txt:2630
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-4-bm117-tests1-linux64-build0.txt:779
> mozilla-central_ubuntu64_vm-debug_test-mochitest-5-bm117-tests1-linux64-build7.txt:487
> mozilla-central_ubuntu64_vm-debug_test-mochitest-1-bm52-tests1-linux64-build13.txt:443
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-3-bm51-tests1-linux64-build2.txt:323
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-1-bm52-tests1-linux64-build17.txt:256
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-5-bm123-tests1-linux64-build7.txt:220
> mozilla-central_ubuntu64_vm-debug_test-mochitest-2-bm120-tests1-linux64-build11.txt:184
> mozilla-central_ubuntu64_vm-debug_test-mochitest-other-bm116-tests1-linux64-build11.txt:159
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-1-bm115-tests1-linux64-build12.txt:77
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-2-bm117-tests1-linux64-build10.txt:73
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-2-bm115-tests1-linux64-build11.txt:65
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-1-bm53-tests1-linux64-build7.txt:30
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-1-bm120-tests1-linux64-build1.txt:27
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-1-bm117-tests1-linux64-build8.txt:19
> mozilla-central_ubuntu64_vm-debug_test-reftest-2-bm120-tests1-linux64-build10.txt:19
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-3-bm120-tests1-linux64-build3.txt:10
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-2-bm114-tests1-linux64-build5.txt:7
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-3-bm114-tests1-linux64-build7.txt:5
> mozilla-central_ubuntu64_vm-debug_test-mochitest-jetpack-bm53-tests1-linux64-build10.txt:2
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-2-bm121-tests1-linux64-build3.txt:1
> mozilla-central_ubuntu64_vm-debug_test-reftest-3-bm114-tests1-linux64-build0.txt:1
> mozilla-central_ubuntu64_vm-debug_test-mochitest-push-bm122-tests1-linux64-build4.txt:1

It shows up in 1970 tests. A few of the most prevalent:

> 256 - layout/base/tests/test_reftests_with_caret.html
> 172 - docshell/test/navigation/test_sessionhistory.html
> 166 - layout/style/test/test_visited_reftests.html
> 108 - dom/base/test/test_bug1091883.html
> 80 - browser/components/sessionstore/test/browser_formdata_cc.js
> 40 - dom/imptests/html/dom/nodes/test_Document-createElement-namespace.html
> 33 - dom/base/test/test_x-frame-options.html
> 32 - browser/base/content/test/general/browser_trackingUI_1.js
> 30 - dom/base/test/test_bug704320_https_https.html
> 30 - dom/base/test/test_bug704320_http_https.html
Blocks: 1182316
No longer depends on: 1182316
OK, so it looks like the main change here is that GetScriptableParent used to just run in whatever window it was in, then call GetParent, which forwarded to the outer.

But https://hg.mozilla.org/mozilla-central/rev/7bb87a230841 make GetScriptableParent forward to inner (and then turn around and forward to outer).

Kyle, that seems odd.  Can we just remove that forward-to-inner bit?  The parent, scriptable or not, really seems like an operation on the outer....
Flags: needinfo?(khuey)
Attached patch PatchSplinter Review
Assignee: nobody → khuey
Status: NEW → ASSIGNED
Flags: needinfo?(khuey)
Attachment #8636463 - Flags: review?(bzbarsky)
Comment on attachment 8636463 [details] [diff] [review]
Patch

r=me
Attachment #8636463 - Flags: review?(bzbarsky) → review+
Bug 1182316 appears to also be responsible for:
> 6477 [NNNNN] WARNING: NS_ENSURE_TRUE(parentWin) failed: file dom/base/ThirdPartyUtil.cpp, line 281

The appearances correlate pretty well with 'No inner window available!' followed by 'NS_ENSURE_TRUE(parentWin) failed'
Yes, it's the same issue: we try to forward the parent window get to the inner, there is no inner, we don't get a parent.  I expect this patch to fix both issues.
https://hg.mozilla.org/mozilla-central/rev/6ad92b48085b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.