Collection creation widget truncates collections to one app in Safari.

RESOLVED WONTFIX

Status

Marketplace
Admin Tools
P3
blocker
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: sdevaney, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

2 years ago
There are likely overlapping issues at play here, but here's the story...

For first time today I could not log in to /curate via Firefox browser (I would get the sign-in pop which was white and blank but that's all). This was the case for me all day, but given Tuesday's priority Egypt launch for FxOS devices, I needed to access /curate to add all Arabic localizations into all past editorial collections. 

So I turned to the Safari browser to access /curate, which allowed me to sign in. However I noticed that on Safari every collection I accessed only displayed one app. I later checked with others who could access admin in /curate on Firefox and they confirmed they could see all apps in any given collection, so it appeared me seeing just one app in every collection was a weird front end issue. 

So I proceeded to add Arabic copy to all collections, and then hit SAVE. After adding Arabic to all relevant collections (most of them) I noticed in the the EDIT view for all featured content that every collection I touched displayed (1) app in the parenthetical. 

This prompted me to check again with Durst, who could access /curate via Firefox and indeed, it appears every collection I saved Arabic copy in also saved the content itself to just one app. 

Can we restore the lost content?
It sounds like this was a bug with the way that the app selection widget works in Safari. We ascertained that the data was actually deleted. Remedial steps:

1) We're backing up the entire database as it is now.
2) We're restoring data for all `mkt_feed_*` tables from the 4/19 backup.
3) We're reindexing the feed.
4) We're flushing the CDN of all URLs prefixed with `/api/v2/feed`.

This just fixes the problems the bug caused, and does not fix the root cause.
Summary: /curate erasing featured content !!! → Collection creation widget truncates collections to one app in Safari.
We should find out the root cause, but since we know this works in Firefox, making it a P3.
Priority: -- → P3

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.