If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

If Tracking Protection UI is on, private browsing windows say "You're browsing privately, Now with Tracking Protection", regardless of whether tracking protection in PB mode is *actually* enabled/disabled

RESOLVED DUPLICATE of bug 1177156

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 1177156
2 years ago
a year ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

(Whiteboard: [fxprivacy])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR:
 1. Turn on privacy.trackingprotection.ui.enabled in about:config
 2. Open a new private browsing window.
 3. Click "Preferences" to inspect your tracking protection settings.

ACTUAL RESULTS:
 - In step 2, the new Private Browsing window says, in huge text...
     You're browsing privately
     Now with Tracking Protection
But, as I discover in step 3, I am actually *not* browsing with tracking protection.

(IIUC, the pref to turn on tracking-protection in private browsing mode will eventually be enabled by default. Still -- for those who disable it, or who have it disabled for them by their enterprise or an addon or whatever, it seems bad that we'll still be misleadingly saying "You're browsing [...] with Tracking Protection" in new private browsing windows.)
(Reporter)

Updated

2 years ago
Summary: If Tracking Protection UI is on, private browsing windows say "You're browsing privately, Now with Tracking Protection", even if tracking protection is disabled → If Tracking Protection UI is on, private browsing windows say "You're browsing privately, Now with Tracking Protection", even if tracking protection in private browsing mode is disabled
(Reporter)

Comment 1

2 years ago
Created attachment 8636416 [details]
screencast of STR / results

Updated

2 years ago
Flags: firefox-backlog?
(Reporter)

Comment 2

2 years ago
I think the *intent* of the current language is to say "...by the way, tracking protection is now also available, and on by default in PB mode"!)

But right now, that subtlety is missing, and it comes off as just saying "You're browsing...with tracking protection", which may or may not actually be true.
(Reporter)

Comment 3

2 years ago
(I am not a wordsmith, but one possible tweak that might nudge this in the direction of correctness would be to add "available" at the end of the sentence. [maybe only when the PB-tracking-protection pref is disabled, if you like]

So e.g. "Now with Tracking Protection available"

That's still probably not great, but it reduces the implication that the feature is turned on (which is good because this page doesn't actually know if it's turned on or not).
(Reporter)

Updated

2 years ago
Summary: If Tracking Protection UI is on, private browsing windows say "You're browsing privately, Now with Tracking Protection", even if tracking protection in private browsing mode is disabled → If Tracking Protection UI is on, private browsing windows say "You're browsing privately, Now with Tracking Protection", regardless of whether tracking protection in PB mode is *actually* enabled/disabled
Whiteboard: [fxprivacy]

Comment 4

2 years ago
Hi Daniel, I actually brought up the case you've noticed and after some discussion the user experience team came up with an alternative design to use for the page in that case, which has been implemented in bug 1177156, that just landed on mozilla-central.

The new design retains the same text in the upper area, and we're providing a button to re-enable Tracking Protection if it has been disabled. I don't know if this handles your concerns, but if you have suggestions for further improvements then Aislinn Grigas from user experience is the person you want to talk to.
(Reporter)

Comment 5

2 years ago
Thanks, Paolo - that sounds great, and it addresses the misleading implication that I filed this bug about.

Duping.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1177156

Updated

2 years ago
Flags: firefox-backlog?
You need to log in before you can comment on or make changes to this bug.