After upgrading to 38.1.0 UI is rendered vertically offset and unusable in Windows 7

RESOLVED INCOMPLETE

Status

Thunderbird
Mail Window Front End
RESOLVED INCOMPLETE
3 years ago
10 months ago

People

(Reporter: rossb, Unassigned)

Tracking

(Blocks: 1 bug)

38 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8636423 [details]
Main Window, showing display vertically offset.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.81 Safari/537.36

Steps to reproduce:

I upgraded to Thunderbird 38.1.0
On Windows 7 SP1 Professional
I launched Thunderbird


Actual results:

In the main window, the display is rendered vertically lower (see screenshot)

In other windows (About window, compose, alert) the display is rendered vertically higher and the top part of the window is not visible.

In all cases, the mouse seems to respond to where the display should be rendered.

It is very difficult to operate the UI when you can't easily click on things.

I have tried this with gfx.direct2d.disabled both set to true and false.


Expected results:

Display should be rendered at correct location.
(Reporter)

Comment 1

3 years ago
Created attachment 8636424 [details]
Write new email, showing vertical offset.
(Reporter)

Comment 2

3 years ago
Created attachment 8636425 [details]
About box, showing vertical offset.
(Reporter)

Comment 3

3 years ago
Created attachment 8636426 [details]
Alert / confirm cancel dialog box showing vertical offset
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 4

3 years ago
Does it happen in safe mode? https://support.mozilla.org/kb/safe-mode
Do you have the newest version of graphics driver?
Component: Untriaged → Mail Window Front End
Flags: needinfo?(rossb)

Updated

3 years ago
See Also: → bug 1186117
(Reporter)

Comment 5

3 years ago
> Does it happen in safe mode?

No.

> Do you have the newest version of graphics driver?

Yes. FYI: Intel HD 3000 on a 3+ year old laptop
Flags: needinfo?(rossb)

Comment 6

3 years ago
Did you figure out which add-on was causing it?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Whiteboard: [addon:?]
(Reporter)

Comment 7

3 years ago
(In reply to Magnus Melin from comment #6)
> Did you figure out which add-on was causing it?

I didn't think to try. Does safe mode only disable add-ons?

Comment 8

3 years ago
Mostly yes. (Also some other minor things like using the default toobar items and such.)
(Reporter)

Comment 9

3 years ago
(In reply to Magnus Melin from comment #6)
> Did you figure out which add-on was causing it?

I have disabled all add-ons and the problem persists.

No plugins are enabled either.

Comment 10

3 years ago
(In reply to rossb from comment #9)
> (In reply to Magnus Melin from comment #6)
> > Did you figure out which add-on was causing it?
> 
> I have disabled all add-ons and the problem persists.
> 
> No plugins are enabled either.

disable hardware acceleration at tools | options | advanced | general
Flags: needinfo?(rossb)

Comment 11

3 years ago
using a non-default theme?
(Reporter)

Comment 12

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #10)
> disable hardware acceleration at tools | options | advanced | general

Disabling hardware acceleration seemed to fix it.
Flags: needinfo?(rossb)
(Reporter)

Comment 13

3 years ago
(In reply to Magnus Melin from comment #11)
> using a non-default theme?

As far as I know it's the default theme.

Comment 14

3 years ago
Thanks for that info.

Please post in this bug report, the text (not a screen shot please) of the graphics section from help | troubleshooting
Flags: needinfo?(rossb)

Updated

3 years ago
See Also: → bug 1131879
(Reporter)

Comment 15

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #14)
> Please post in this bug report, the text (not a screen shot please) of the
> graphics section from help | troubleshooting

Graphics
Adapter Description	Intel(R) HD Graphics 3000
Vendor ID	0x8086
Device ID	0x0126
Adapter RAM	Unknown
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Driver Version	9.17.10.3517
Driver Date	3-20-2014
Direct2D Enabled	false
DirectWrite Enabled	false (6.2.9200.16571)
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
WebGL Renderer	false
GPU Accelerated Windows	0
AzureCanvasBackend	skia
AzureSkiaAccelerated	0
AzureFallbackCanvasBackend	cairo
AzureContentBackend	cairo

Let me know if you need anything else.
Flags: needinfo?(rossb)
(Reporter)

Comment 16

3 years ago
The previous dump was with hardware acceleration disabled in the advanced options. Now here is the dump with acceleration enabled and the bug present:

Graphics
Adapter Description	Intel(R) HD Graphics 3000
Vendor ID	0x8086
Device ID	0x0126
Adapter RAM	Unknown
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Driver Version	9.17.10.3517
Driver Date	3-20-2014
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
WebGL Renderer	false
GPU Accelerated Windows	1/1 OpenGL
AzureCanvasBackend	direct2d 1.1
AzureSkiaAccelerated	0
AzureFallbackCanvasBackend	cairo
AzureContentBackend	direct2d 1.1
(Reporter)

Comment 17

3 years ago
I'm reopening this because the but is still present when hardware acceleration is enabled, with no plug-ins enabled.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

3 years ago
Blocks: 1195947

Updated

3 years ago
See Also: → bug 1185628
rossb, 
Do you still see this when using beta from http://www.mozilla.org/en-US/thunderbird/channel/ or version 45?

Note - similar issue reported in bug 1185205
Flags: needinfo?(rossb)
(Reporter)

Comment 19

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #18)
> rossb, 
> Do you still see this when using beta from
> http://www.mozilla.org/en-US/thunderbird/channel/ or version 45?
> 
> Note - similar issue reported in bug 1185205

The bug is still present in 45.5.1 (release channel)

Specifically: when "Use hardware acceleration when available" is selected in Options > Advanced > General, then the UI is offset as in the screenshots attached to this ticket.
Also, is it better with beta version from http://www.mozilla.org/en-US/thunderbird/channel/ ?
(Reporter)

Comment 21

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #20)
> Also, is it better with beta version

Sorry, I'm running a business here. I'm not prepared to run a beta version.
No problem. Check back please when the new release is out in April
Whiteboard: [addon:?] → [closeme 2017-04-01]

Comment 23

10 months ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago10 months ago
Flags: needinfo?(rossb)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2017-04-01]
You need to log in before you can comment on or make changes to this bug.