[Windows 10] Close tab icon is incorrectly displayed for DevEdition Theme on Nightly

VERIFIED FIXED in Firefox 41

Status

()

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: cornel_ionce, Assigned: ntim)

Tracking

(Blocks 1 bug)

42 Branch
Firefox 42
All
Windows 10
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox41+ verified, firefox42 verified)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150720030213

STR:
1. Open Nightly using a clean profile.
2. Go to abount:addons -> Appearance tab.
3. Enable the "Developer Edition" theme.

Expected Results:
The Developer Edition theme is properly enabled, there should be no UI issues.

Actual Results:
The close tab (X) button is very big and just partially displayed.

Screenshot: http://i.imgur.com/35d7CPl.png

Notes:
1. This issue is a recent regression.
2. The icon is blurry on a regular display (not blurry on HiDPI).
3. The icon is displayed at the normal size when hovered.


Regression Range:
Last-good buildID: 20150717030202
First-bad buildID: 20150718030211
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=15155971639c&tochange=d317a93e5161
Assignee

Updated

4 years ago
Duplicate of this bug: 1185295
Assignee

Updated

4 years ago
Blocks: 1173729
The larger icon is expected from bug 1173729, but it being cut-off is not. Might be worth considering if devtools should use a different shape, though... The round icon seems a little out of place with the square tabs.
Flags: needinfo?(shorlander)
Priority: -- → P1
Assignee

Comment 3

4 years ago
Posted patch PatchSplinter Review
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Attachment #8637237 - Flags: review?(dao)
Attachment #8637237 - Flags: review?(dao) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/08cf05d407fc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Assignee

Comment 6

4 years ago
Comment on attachment 8637237 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1173729
[User impact if declined]: Broken close button look
[Describe test coverage new/current, TreeHerder]: on m-c, tested locally
[Risks and why]: low, straightforward css fix
[String/UUID change made/needed]: none
Attachment #8637237 - Flags: approval-mozilla-beta?
Attachment #8637237 - Flags: approval-mozilla-aurora?
If this is only an issue on Dev Edition, do we need the fix in 40 and 41 as we will first support Windows 10 when Firefox 40 releases and Dev Edition is 42?
Flags: needinfo?(ntim.bugs)
Flags: qe-verify+
QA Contact: cornel.ionce
Assignee

Comment 8

4 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #7)
> If this is only an issue on Dev Edition, do we need the fix in 40 and 41 as
> we will first support Windows 10 when Firefox 40 releases and Dev Edition is
> 42?
The issue is on the devedition theme alltogether.
But since that theme can't be enabled on Beta, it's fine not to uplift this fix there. (see bug 1181721).
Flags: needinfo?(ntim.bugs)
Assignee

Updated

4 years ago
Attachment #8637237 - Flags: approval-mozilla-beta?
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #7)
> If this is only an issue on Dev Edition, do we need the fix in 40 and 41 as
> we will first support Windows 10 when Firefox 40 releases and Dev Edition is
> 42?

We are hoping that Win 10 Dev Edition theme will be ready in 41 / the initial release of Win 10.  There are just a few bugs that will need uplift to make that possible (this one included).  No need to push this to beta though.
As of today (2015-07-23), I'm also seeing this on DevEdition. We should uplift this fix to 41 as soon as possible.

Verified fixed on latest Nightly (build ID: 20150723030207).
Comment on attachment 8637237 [details] [diff] [review]
Patch

Fix was verified on nightly, let's uplift to Aurora.
Attachment #8637237 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1187650
Assignee

Comment 14

4 years ago
Comment on attachment 8637237 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: Windows 10
[User impact if declined]: None, but eases up future fixes to be uplifted
[Describe test coverage new/current, TreeHerder]: baked on m-c and aurora, QA verified the fix on Nightly
[Risks and why]: Low, CSS only fix with no issues found so far
[String/UUID change made/needed]: none
Attachment #8637237 - Flags: approval-mozilla-beta?
See Also: → 1188176
Duplicate of this bug: 1187669
Comment on attachment 8637237 [details] [diff] [review]
Patch

We're building our final beta tomorrow and will no longer take nice to have or speculative fixes. Unless this is a prereq for one of the Windows 10 related fixes that we're taking in beta9, it will need to wait for 41. Beta-
Attachment #8637237 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Updated

4 years ago
Duplicate of this bug: 1189422
I have successfully reproduced this bug on Firefox nightly 42.0a1 (2015-07-21)

I found this fix on latest Firefox aurora 41.0a2 (2015-07-31)

Build ID : 20150731004008
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0

[bugday-20150729]
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

Confirming this fix for latest 41.0a2 Aurora, build ID: 20150802004005
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1187568
Untracked bug 1187568, adding a tracking flag here instead to be safe.
See Also: 1188176
You need to log in before you can comment on or make changes to this bug.