[ACL][Whatsapp]Send picture takes more than 10s

RESOLVED FIXED

Status

Tech Evangelism
Preinstalled B2G Apps
P2
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mlien, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox 34

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
[Step to reproduce]
Choose one contact to compose message -> Attachment -> Photo -> Camera -> Take a picture then send

[Actual Result]
It takes more than 10s to send
Even in the same network environment, it takes more than twice times against Whatsapp in Android

Updated

3 years ago
Priority: -- → P2
(Reporter)

Comment 1

3 years ago
verify with ACL 0.1.19 and Whatsapp 2.12.157-omrel1.0.10, still has this problem
Validated sending picture works as designed.  It may be slower on OpenC2 than some other platforms, but this is caused by hardware, OS, or WhatsApp, and is not an ACL issue.

Resolved Invalid/Won't Fix
(Reporter)

Comment 3

3 years ago
verify with ACL 0.1.39 and Whatsapp 2.12.252-omrel1.0.13, still has this problem

Compare with sending picture with Whatsapp captured image, Firefox OS Gallery file, and Firefox OS captured image.
The result is Firefox OS captured image will take 10s to finish sending. If this is Whatsapp issue, agree to WONTFIX
(Reporter)

Comment 4

2 years ago
verified and fixed with ACL 0.1.72 and Whatsapp 2.12.287-omrel1.0.20

Sending picture with Whatsapp captured image, Firefox OS Gallery file, and Firefox OS captured image are all around 5s~10s
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.