[TSF] Rename nsTextStore to mozilla::widget::TSFTextStore

RESOLVED FIXED in Firefox 42

Status

()

--
enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({inputmethod})

Trunk
mozilla42
x86
Windows
inputmethod
Points:
---

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment)

I think that we should move nsTextStore from global namespace to mozilla::widget. Then, nsTextStore.h can be simpler.
Created attachment 8637865 [details] [diff] [review]
Rename nsTextStore to mozilla::widget::TSFTextStore

Renaming widget/windows/nsTextStore.* -> widget/windows/TSFTextStore.*

nsTextStore -> mozilla::widget::TSFTextStore

I was thinking the new name should be TextStore. However, it's not clear what the file implements. Therefore, I think that it's better to add TSF prefix for TSF related classes like TSFStaticSink.
Attachment #8637865 - Flags: review?(m_kato)
Attachment #8637865 - Flags: review?(jmathies)
Summary: [TSF] Rename nsTextStore to mozilla::Widget::TextStore → [TSF] Rename nsTextStore to mozilla::widget::TSFTextStore
Comment on attachment 8637865 [details] [diff] [review]
Rename nsTextStore to mozilla::widget::TSFTextStore

Review of attachment 8637865 [details] [diff] [review]:
-----------------------------------------------------------------

nice clean code, thanks!

::: widget/windows/TSFTextStore.cpp
@@ +21,5 @@
>  #define TEXTATTRS_INIT_GUID
> +#include "TSFTextStore.h"
> +
> +namespace mozilla {
> +namespace widget {

great!

@@ +730,5 @@
>      *pprgInputScopes = pScope;
>      return S_OK;
>    }
>  
> +  STDMETHODIMP GetPhrase(BSTR **ppbstrPhrases, UINT* pcCount)

was this an 80 character limit change? This seems out of place to me this way. Not a big deal though.
Attachment #8637865 - Flags: review?(jmathies) → review+
> @@ +730,5 @@
>>      *pprgInputScopes = pScope;
>>      return S_OK;
>>    }
>>  
>> +  STDMETHODIMP GetPhrase(BSTR **ppbstrPhrases, UINT* pcCount)
> 
> was this an 80 character limit change? This seems out of place to me this way. Not a big deal though.

Yes. When I fix BSTR** style, I included the fix.
Comment on attachment 8637865 [details] [diff] [review]
Rename nsTextStore to mozilla::widget::TSFTextStore

Review of attachment 8637865 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/windows/TSFTextStore.cpp
@@ +1217,5 @@
>    return false;
>  }
>  
>  /******************************************************************/
> +/* TSFTextStore                                                    */

remove one space character.
Attachment #8637865 - Flags: review?(m_kato) → review+
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/807550417c75cc76e2acb417861063c3fa720cbd
changeset:  807550417c75cc76e2acb417861063c3fa720cbd
user:       Masayuki Nakano <masayuki@d-toybox.com>
date:       Fri Jul 24 14:07:39 2015 +0900
description:
Bug 1186014 Rename nsTextStore to mozilla::widget::TSFTextStore r=jimm+m_kato
https://hg.mozilla.org/mozilla-central/rev/807550417c75
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.