If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Certificate import failure dialog too vague

UNCONFIRMED
Unassigned

Status

()

Core
Security: PSM
P3
normal
UNCONFIRMED
2 years ago
a year ago

People

(Reporter: Jonathon Reinhart, Unassigned)

Tracking

(Depends on: 1 bug)

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [psm-blocked])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.132 Safari/537.36

Steps to reproduce:

I'm trying to import the DoD CA certs from <http://iasecontent.disa.mil/pki-pke/Certificates_PKCS7_v4.1_DoD.zip> into Firefox 38.0.5 on Fedora 22, on the "Authorities" tab.


Actual results:

When I do so, only one (the first) of the multiple certs in the pkcs7 file is successfully imported (DoD Root CA 3).  All of the others fail with the "This certificate can't be verified and will not be imported" message.  

This message is incredibly unhelpful:
- Which certificiate couldn't be imported?
- Why *exactly* couldn't it be imported?

Right now, FireFox gives zero useful information to correct the issue.


Expected results:

The certificates should have been imported successfully.

Updated

2 years ago
Component: Untriaged → Security: UI
Product: Firefox → Core
If we fix bug 1257403, this will be moot.
Component: Security: UI → Security: PSM
Depends on: 1257403
Priority: -- → P3
Whiteboard: [psm-blocked]
You need to log in before you can comment on or make changes to this bug.