Quite hangs system while trying to load this page. Seems go get into a loop...

RESOLVED DUPLICATE of bug 113235

Status

()

Core
Layout: Tables
P2
critical
RESOLVED DUPLICATE of bug 113235
16 years ago
16 years ago

People

(Reporter: Thomas Piraja Hansen, Assigned: karnaze (gone))

Tracking

({perf})

Trunk
mozilla1.1alpha
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

This page is original from www.uol.com.br, the most important ISP in Brazil.
It's first page presents also a bug, yet related. The original place of this
page was http://www.uol.com.br/folha/cotidiano/2001-sequestro.shtml, but I am
not sure if it is going to stay long there, so I copied it to another website.
While loading this page, CPU usage reaches 100%, mouse gets laggy, and the page
is not shown properly. All problems stops if I click the stop button. Maybe a
kind of loop?

Reproducible: Always
Steps to Reproduce:
1.Open page http://www.geocities.com/thomasphansen/problem.html
2.
3.

Actual Results:  System gets very slow, CPU usage reaches 100%.

Expected Results:  Open the page without this problems :)

Comment 1

16 years ago
Able to re-produce the problem on Windows NT SP5 and Mozilla 2002010703...
Using Netscape 4.7 this problem doesn _not_ occur on my system.

Comment 2

16 years ago
The URL given worked ok, but the "original" did have this problem.  They appear
to be completely different.  

Not counting any tags produced by JavaScript, the "original" document has 41
<table> tags and only 21 </table> tags.  The page rarely uses <td> tags, and
often uses </tr> tags without <tr>.  After pruning the file somewhat, it loads
eventually (it is still quite slow) and displays ok.

The highly nested tables, bad HTML and large file size are probably responsible
for the bad behavior.

Comment 3

16 years ago
->tables
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLTables
Ever confirmed: true
QA Contact: doronr → amar
(Reporter)

Comment 4

16 years ago
I had to change the location of the page, due to change of my homepage address. 
The new URL is http://www.oarauto.com/thomas/problem.html. 

(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
Takes approx 15 seconds to load on 750Mhz AMD machine running WindowsXP using
2002020512 build. It does not crash for me.

amar: Can you try this URL on Linux? thanks!
Target Milestone: mozilla1.0 → mozilla1.1

Comment 6

16 years ago
 On linux 7.1 its taking approx 1 minute to load the page but during that 
process it uses 100% cpu.
On win2k it takes more than 2 munites to load the page where as IE takes just 
3-5 seconds to load the page. Marking the priority of this bug to P2 due to its 
high visibility.
Priority: -- → P2

Comment 7

16 years ago
 Its a performance issue. There are a lot of link with <a href> tags. Adding
perf keyword.
Keywords: perf

Comment 8

16 years ago
URL loads fine with trunk build 20020501, but not 20020430.

Comment 9

16 years ago
linux branch build 20020503 (1.0rc2) still has problems here (~1.5 minutes to
load on PII-450MHz).

Comment 10

16 years ago
whatever fixed this on the trunk made it in between 2002043007 and 2002043021

I can remove <img>, <a>, <tr> and <td> and still get problems.  <br> tags and
unclosed <table> and <font> tags seem to be the necessary components for this bug.

Comment 11

16 years ago
there have been several checkins like for bug 113235 and bug 138292 to the trunk
(Assignee)

Comment 12

16 years ago
Marking a dup of bug 113235 based on comment #10. It would be nice if 
someone with a branch build could verify.

*** This bug has been marked as a duplicate of 113235 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.