Closed Bug 1186121 Opened 5 years ago Closed 4 years ago

Generate locale-aware remote new tab pages

Categories

(Firefox :: New Tab Page, defect, P1)

40 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: oyiptong, Assigned: marcosc)

References

(Blocks 1 open bug, )

Details

Using something very similar to fhr-jelly, generate locale-aware remote newtab pages.

The generated pages need to be aware of versions. While we can have only one version in the beginning, this is important so that we can add functionality to Firefox on an ongoing basis.

The locale should surface in the generate pages' paths. e.g.

v1/en-US/index.html
v1/fr-FR/index.html

The pages will have all the JS and CSS necessary for a fully working new tab page. Content will be injected in the page as per bug 1180298
QA Contact: mzhilyaev
Assignee: nobody → mzhilyaev
QA Contact: mzhilyaev
This bug should also take care of localization automation in the CI and deployment scripts
Assignee: mzhilyaev → nobody
Automation and deployment tracked separately
Assignee: nobody → oyiptong
No longer blocks: landing-remote-newtab
Assignee: oyiptong → mcaceres
Priority: -- → P1
Duplicate of: 
- https://github.com/mozilla/remote-newtab/issues/162
- https://github.com/mozilla/remote-newtab/issues/163
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.