Closed Bug 1186261 Opened 5 years ago Closed 5 years ago

Intermittent timeout with media-source/mediasource-config-change-webm-*-bitrate.html

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1195073
Tracking Status
firefox42 --- affected

People

(Reporter: jya, Unassigned)

References

Details

Attachments

(1 file)

media-source/mediasource-config-change-webm-a-bitrate.html
and
media-source/mediasource-config-change-webm-av-audio-bitrate.html 

intermittently timeout on linux and windows XP.

Now, the test itself appears wrong:
It calls:
mediaSourceConfigChangeTest

This is defined in mediasource-config-changes.js

This calls first thing:
var sourceBuffer = mediaSource.addSourceBuffer(typeA);

now on Linux this will throw a NS_ERROR_DOM_NOT_SUPPORTED_ERR exception.

The test will only abort early on the media element failing.

Will disable the test for the time being and report the problem upstream.

Will leave open until the problem is fixed upstream.
Blocks: 1171379
Those tests do not properly check that mediasource is not available and do not behave in a reliable fashion.
Attachment #8636872 - Flags: review?(karlt)
Attachment #8636872 - Flags: review?(karlt) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1195073
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.