there is no notification after tapping on Check for updates

RESOLVED DUPLICATE of bug 1193910

Status

RESOLVED DUPLICATE of bug 1193910
3 years ago
3 years ago

People

(Reporter: isandu, Unassigned, NeedInfo)

Tracking

({dogfood, feature, regression})

unspecified
dogfood, feature, regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [bzlite],[systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Like the title says, nothing happens.
blocking-b2g: --- → 2.5+
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::System
Keywords: feature
Whiteboard: [bzlite] → [bzlite],[systemsfe]
[Blocking Requested - why for this release]:
blocking-b2g: 2.5+ → 2.5?
Can QA confirm?
blocking-b2g: 2.5? → 2.5+
Keywords: qawanted

Updated

3 years ago
QA Contact: ddixon
Branch Check for bug 

https://bugzilla.mozilla.org/show_bug.cgi?id=1186332

Issue DOES occur in Flame 2.5, 2.2

Actual Results: Tapping "Check Now" reveals the text "Checking For Updates", but there is no notification shown if updates were found.
 
Device: Aries 2.5
BuildID: 20150803134730
Gaia: 8dba2077f5e7137253fbb3faf10cd0b5f7da25c2
Gecko: 1d4f44ee5166
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
----------------------------------------------------  
Device: Flame 2.5
BuildID: 20150803045939
Gaia: 8dba2077f5e7137253fbb3faf10cd0b5f7da25c2
Gecko: b9f166a815b2
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
----------------------------------------------------
Device: Flame 2.2
BuildID: 20150803070837
Gaia: f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gecko: f15bd4bdff6e
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
----------------------------------------------------
----------------------------------------------------
Issue DOES NOT occur in Flame 2.1  

Device: Flame 2.1
BuildID: 20150723133047
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [foxfood-triage] → [foxfood-triage][QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [foxfood-triage][QAnalyst-Triage?] → [foxfood-triage][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regression, regressionwindow-wanted
B2G Inbound Regression Window

Last Working 

Device: Flame 2.2
BuildID: 20150109125935
Gaia: 276b0d36bb6d68c7c866005c16d7da30fff9d4e0
Gecko: 20a4b3274754
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 37.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken 

Device: Flame 2.2
BuildID: 20150109135741
Gaia: 8e16fa9e481eceefa1ea6fd7fa86c32969cde41f
Gecko: 40853b2ad772
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 37.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working Gaia and First Broken Gecko
Issue DOES occur here: 
Gaia: 276b0d36bb6d68c7c866005c16d7da30fff9d4e0
Gecko: 40853b2ad772

Last Working Gecko and First Broken Gaia
Issue DOES NOT occur here: 
Gaia: 8e16fa9e481eceefa1ea6fd7fa86c32969cde41f
Gecko: 20a4b3274754

B2G Inbound Pushlog (Gecko):
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=20a4b3274754&tochange=40853b2ad772

Possible Cause: 
Bug 1090820 - OTA update check never clears status
Blocks: 1090820
QA Whiteboard: [foxfood-triage][QAnalyst-Triage+] → [foxfood-triage][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Markus, can you take a look at this please? This looks to have been caused by the work done for bug 1090820.
QA Whiteboard: [foxfood-triage][QAnalyst-Triage?] → [foxfood-triage][QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(markus.nilsson)

Comment 6

3 years ago
Bug 1090820 solved a crash that was introduced by bug 1077529.
When I read through the code I can't come up with any explanation other than that for this issue to "work", the code needs to crash. But if that is the case, it shouldn't work before bug 1077529 introduced it.

Sadly, I don't know how to test this issue, so Duane could you give me detailed instructions on how to that or please check if it worked before bug 1077529?

Thanks.
Flags: needinfo?(markus.nilsson) → needinfo?(ddixon)
Hi Markus, here is an explanation of the bug. 

Repro Steps: 
1. Go to Settings>Device Information
2. Scroll down to Check for Updates
3. Select "Check Now"  

Actual Results: 
The text "Checking for updates..." will appear then quickly disappear from view, and the user is NOT notified if the check was successful/unsuccessful.  

Expected Results: 
Tapping on "Check Now" causes the text "Checking for updates..." to appear, and when the check concludes, the user is notified if the check was successful/unsuccessful.  The text "No updates were found" should remain if no OTA updates are availble.   

Yes, the bug does NOT repro prior to bug 1077529 (10/3/14)

Working Build: 
Device: Flame 2.2
BuildID: 20141001054220
Gaia: 0e280591881d44b80f456bc27e12d9114c218868
Gecko: 49d21726b9dd
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 35.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Video of Correct Behavior: 
http://youtu.be/k4SJOiicCOc

Video of bug: 
http://youtu.be/7c727y7D7lE

I also attached a logcat of this bug. 

There is also a feature request to implement the correct behavior (by the same reporter): 
Bug 1181664 - add notification that the system is checking for updates

Hope this helps!
Flags: needinfo?(ddixon) → needinfo?(markus.nilsson)
Created attachment 8643158 [details]
10.1.14_build_log.txt

Comment 9

3 years ago
This almost looks like a dupe of bug 1176226 to me. Maybe nhirata knows more?
Flags: needinfo?(nhirata.bugzilla)
I believe that this is a dup of bug 1176226 as per what Ton suggested.  At the same time, the regression window is found here.  We should dup one to the other.
Flags: needinfo?(nhirata.bugzilla)
Duplicate of this bug: 1176226
Alex, can you help out here?
Flags: needinfo?(lissyx+mozillians)
Could people check logs before?

> 08-04 12:25:50.388   209   209 I GeckoConsole: AUS:SVC Checker:onLoad - number of updates available: 0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(lissyx+mozillians)
Resolution: --- → WORKSFORME
Irina, you have a Flame running JB base system. This is deprecated since more than a year now. Please update to latest KK base system image as documented on MDN.
Flags: needinfo?(isandu)
(Reporter)

Comment 15

3 years ago
This is not from a Flame, but from a Sony device that I got at Whistler. Not sure why the log would say otherwise.
Status: RESOLVED → REOPENED
Flags: needinfo?(isandu)
Resolution: WORKSFORME → ---
(In reply to Irina Sandu from comment #15)
> This is not from a Flame, but from a Sony device that I got at Whistler. Not
> sure why the log would say otherwise.

Please provide the proper log then.
Flags: needinfo?(isandu)
So I got the log and the device is already update. Duane, all your regressions windows are just wrong: this is on a Flame JB. It's unusable. I'm not able to tell if there's a bug. My Z3c with a build from july 25th exposes a proper behavior.
Flags: needinfo?(isandu) → needinfo?(ddixon)
I think part of this will be fixed with Bug 1161927.
QAWANTED: There's some fixes in bug 1187668; we need to retest.
Keywords: qawanted
(In reply to Alexandre LISSY :gerard-majax from comment #17)
> So I got the log and the device is already update. Duane, all your
> regressions windows are just wrong: this is on a Flame JB. It's unusable.
> I'm not able to tell if there's a bug. My Z3c with a build from july 25th
> exposes a proper behavior.

Sorry, if the information I provided doesn't help resolve this issue.  Our technique to find regression windows does not involve using an Aries device (Z3c), hence why I used an older branch with a Flame device; where I saw the last working/first broken builds. Pasted below is a section of a Flame KK logcat that involves the AUS:SVC lines drawn from the latest nightly build and base we have for Flame.  

And it sounds like qawanted should retest after Bug 1161927 has landed. 

------------------------------------------
Environmental Variables:
Device: Flame 2.5 (full flash)
Build ID: 20150810030209
Gaia: 09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gecko: 0e269a1f1beb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
------------------------------------------


08-10 07:51:33.026   215   215 I Gecko   : *** AUS:SVC UpdateService:_offlineStatusChanged - network is online, forcing another background check
08-10 07:51:33.026   215   215 I GeckoConsole: AUS:SVC UpdateService:_offlineStatusChanged - network is online, forcing another background check
08-10 07:51:33.026   215   215 I Gecko   : *** AUS:SVC UpdateService:_attemptResume
08-10 07:51:33.026   215   215 I GeckoConsole: AUS:SVC UpdateService:_attemptResume
08-10 07:51:33.026   215   215 I Gecko   : *** AUS:SVC Checker: checkForUpdates, force: false
08-10 07:51:33.026   215   215 I GeckoConsole: AUS:SVC Checker: checkForUpdates, force: false
08-10 07:51:33.086   219   219 V WLAN_PSA: NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
08-10 07:51:33.096   215   215 I Gecko   : *** AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/42.0a1/20150810030209/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/update.xml
08-10 07:51:33.096   215   215 I GeckoConsole: AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/42.0a1/20150810030209/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/update.xml
08-10 07:51:33.096   215   215 I Gecko   : *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/42.0a1/20150810030209/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/update.xml
08-10 07:51:33.096   215   215 I GeckoConsole: AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/42.0a1/20150810030209/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/update.xml
08-10 07:51:33.166   219   219 V WLAN_PSA: NL MSG, len[914], NL type[0x11] WNI type[0x5050] len[894]
08-10 07:51:33.266   219   219 V WLAN_PSA: NL MSG, len[914], NL type[0x11] WNI type[0x5050] len[894]
08-10 07:51:33.266   219   219 V WLAN_PSA: NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
Flags: needinfo?(ddixon)

Comment 21

3 years ago
I may be wrong but thought bug 1176226 comment 2 kind of explained why the "No updates were found" message actually *is* displayed, but for a very short (random) time and hence only sometimes noticeable.

That bug was about Flame KK and the notification not appearing while logcat says "number of updates available: 0" and "gecko.updateStatus: no-updates" as explained in comment 7 and logcat in comment 8. Looking at the log in comment 20, we might be drifting, or this is another issue, but I may be wrong there as well.
Comment 7 has a corrupt video.  Here is the correct behavior video from my "last working" build from comment 4.

Video of correct behavior: http://youtu.be/OrgJgZ9thp4
(In reply to Duane Dixon [:ddixon] from comment #22)
> Comment 7 has a corrupt video.  Here is the correct behavior video from my
> "last working" build from comment 4.
> 
> Video of correct behavior: http://youtu.be/OrgJgZ9thp4

That is the behavior I have on builds from July 25th ...
(In reply to Alexandre LISSY :gerard-majax from comment #23)
> (In reply to Duane Dixon [:ddixon] from comment #22)
> > Comment 7 has a corrupt video.  Here is the correct behavior video from my
> > "last working" build from comment 4.
> > 
> > Video of correct behavior: http://youtu.be/OrgJgZ9thp4
> 
> That is the behavior I have on builds from July 25th ...

And that I don't have on builds from August 8th.
This issue is still occurring on today's Aries. After tapping on "Check Now", below the Check Now button displays "Checking for updates..." for a second, and then the text is gone without saying whether there's an update or not.

We've checked this issue for both when there's an update and when there's not, and it behaves the same (except when there's an update, it displays in the notification tray). I personally have not seen it showing the correct behavior, but we have other testers here who have seen it displaying 'no update' after checking, this seems to only happen on first attempt after flashing, but I've not seen it after factory resetting.

Tested and issue still occurs on:
Device: Aries 2.5
BuildID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [foxfood-triage][QAnalyst-Triage+] → [foxfood-triage][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [foxfood-triage][QAnalyst-Triage?] → [foxfood-triage][QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 26

3 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #24)
> > > Video of correct behavior: http://youtu.be/OrgJgZ9thp4
> > 
> > That is the behavior I have on builds from July 25th ...
> 
> And that I don't have on builds from August 8th.

That would indicate the issue to have disappeared and returned. Note that the issue is as old as June 19 when 1176226 was filed or even before that date (in fact I flashed a new Flame to base 18Dv2 and nightly 2.2 around May 20 and have never seen the update message working properly) and I’m not sure if anyone worked on this recently. Alex, what base image version do you use and could this be related?

Also, when looking at the INcorrect behavior video (http://youtu.be/7c727y7D7lE), one can see the message is displayed for a very short time at first check (and pause it) just before 00:05.

Yura, could you elaborate on your comment I referred to?
will try to see what's up on the gaia side of things. AFAIK, setting on update check simply parse events coming from gecko and do not set the state in the UI so it could very well be device dependent.
Flags: needinfo?(yzenevich)
So here are more details (tested on Sony device):

Check for updates checks for both gecko updates and apps updates (this is not clear from UI):

The update status is only displayed under the following conditions: either there are no updates, already has latest version or operation needs to be retried when the device is back online.

I could only reproduce a case where the reported status says check completed (none of the above) and thus not text status is displayed. 

There is an UX issue where the status above will be hidden as soon as one of the checks completes
Flags: needinfo?(yzenevich)
FYI not tried it on Flame and the results are get are different:
gecko.updateStatus : no-updates
apps.updateStatus : check-complete

Which is consistently different from Sony device indicating that it is device dependent.
s/not/now

Updated

3 years ago
Duplicate of this bug: 1201218
Assignee: nobody → dale
Maybe instead of having the settings display the "no updates" or "updates available"; we move this as a notification to the system?
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #32)
> Maybe instead of having the settings display the "no updates" or "updates
> available"; we move this as a notification to the system?

Why not, bug 1194642 is about that kind of changes.
Blocks: 1194642
I do not have an aries available for dev at the moment, I dropped my dogfood device and broke its screen so now my dev aries is my only phone. Jean is shipping me a new device and fedex said it should be here by tuesday so I will pick this bug up when I get the device if it isnt closed by then (or closed by the flame issue), but deassigning myself in case someone can pick it up before that.
Assignee: dale → nobody
So its fairly clear, notifications are only shown if there are updates, in the case of no updates the current code is will hide the 'no-updates' text as soon as it is shown, its the same on any device. In 1193910 have a patch to show the notice to the user for a certain period of time.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193910
You need to log in before you can comment on or make changes to this bug.