If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TBIRD 38.1.0 crashing in Filters

RESOLVED DUPLICATE of bug 1163132

Status

Thunderbird
Filters
--
critical
RESOLVED DUPLICATE of bug 1163132
2 years ago
2 years ago

People

(Reporter: Tim, Unassigned)

Tracking

({crash})

38 Branch
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

I did nothing.


Actual results:

Auto Update to 38.1.0 - Thunderbird now crashes retrieving email - many times.  Appears to crash when retrieving the very last last email.

AdapterDeviceID: 0x2539
AdapterDriverVersion: 2.7.1.6
AdapterSubsysID: 00c0102b
AdapterVendorID: 0x102b
Add-ons: lookout%40aron.rubin:1.2.13,sendlater3%40kamens.us:4.4.1,mailmerge%40example.net:3.10.1,%7B1A2D0EC4-75F5-4c91-89C4-3656F6E44B68%7D:0.6.3.1-signed,%7B9ab67d74-ec41-4cb2-b417-df5d93ba1beb%7D:1.5.3.1.1-signed,%7Ba0faa0a4-f1a7-4098-9a74-21efc3a92372%7D:28.0.0.1-signed,%7Bada4b710-8346-4b82-8199-5de2b400a6ae%7D:2.1.5.2.1-signed,abusixspamreporter%40simon.pirschel:1.0.2,%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D:4.0.1,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:17.0.3
AvailablePageFile: 16435265536
AvailablePhysicalMemory: 24743186432
AvailableVirtualMemory: 3833274368
BIOS_Manufacturer: Dell Inc.
BlockedDllList: 
BreakpadReserveAddress: 42205184
BreakpadReserveSize: 67108864
BuildID: 20150311003753
CrashTime: 1437568918
EMCheckCompatibility: true
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
InstallTime: 1437568199
Notes: AdapterVendorID: 0x102b, AdapterDeviceID: 0x2539, AdapterSubsysID: 00c0102b, AdapterDriverVersion: 2.7.1.6
D3D11-WARP? D3D11-WARP+ D3D11 Layers? D3D11 Layers- 
ProductID: {3550f703-e582-4d05-9a08-453d09bdfdc6}
ProductName: Thunderbird
ReleaseChannel: beta
SecondsSinceLastCrash: 654
StartupTime: 1437568895
SystemMemoryUsePercentage: 27
Theme: classic/1.0
Throttleable: 1
TotalPageFile: 45194235904
TotalPhysicalMemory: 34353840128
TotalVirtualMemory: 4294836224
URL: 
Vendor: 
Version: 37.0
Winsock_LSP: MSAFD Tcpip [TCP/IP] : 2 : 1 :  
 MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD Tcpip [RAW/IP] : 2 : 3 :  
 MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
 MSAFD Tcpip [UDP/IPv6] : 2 : 2 :  
 MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
 RSVP TCPv6 Service Provider : 2 : 1 :  
 RSVP TCP Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
 RSVP UDPv6 Service Provider : 2 : 2 :  
 RSVP UDP Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.


Expected results:

Should not crash - tried older version - still crashing.
1. what is your crash ID?
 see https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-reports
2. does crashing cease if you staart thunderbird in safe mode? 
  see https://support.mozilla.org/en-US/kb/safe-mode
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

2 years ago
(In reply to Tim from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101
> Firefox/39.0
> Build ID: 20150630154324
> 
> Steps to reproduce:
> 
> I did nothing.
> 
> 
> Actual results:
> 
> Auto Update to 38.1.0 - Thunderbird now crashes retrieving email - many
> times.  Appears to crash when retrieving the very last last email.
> 
> AdapterDeviceID: 0x2539
> AdapterDriverVersion: 2.7.1.6
> AdapterSubsysID: 00c0102b
> AdapterVendorID: 0x102b
> Add-ons:
> lookout%40aron.rubin:1.2.13,sendlater3%40kamens.us:4.4.1,mailmerge%40example.
> net:3.10.1,%7B1A2D0EC4-75F5-4c91-89C4-3656F6E44B68%7D:0.6.3.1-signed,
> %7B9ab67d74-ec41-4cb2-b417-df5d93ba1beb%7D:1.5.3.1.1-signed,%7Ba0faa0a4-f1a7-
> 4098-9a74-21efc3a92372%7D:28.0.0.1-signed,%7Bada4b710-8346-4b82-8199-
> 5de2b400a6ae%7D:2.1.5.2.1-signed,abusixspamreporter%40simon.pirschel:1.0.2,
> %7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D:4.0.1,%7B972ce4c6-7e08-4474-a285-
> 3208198ce6fd%7D:17.0.3
> AvailablePageFile: 16435265536
> AvailablePhysicalMemory: 24743186432
> AvailableVirtualMemory: 3833274368
> BIOS_Manufacturer: Dell Inc.
> BlockedDllList: 
> BreakpadReserveAddress: 42205184
> BreakpadReserveSize: 67108864
> BuildID: 20150311003753
> CrashTime: 1437568918
> EMCheckCompatibility: true
> FramePoisonBase: 00000000f0de0000
> FramePoisonSize: 65536
> InstallTime: 1437568199
> Notes: AdapterVendorID: 0x102b, AdapterDeviceID: 0x2539, AdapterSubsysID:
> 00c0102b, AdapterDriverVersion: 2.7.1.6
> D3D11-WARP? D3D11-WARP+ D3D11 Layers? D3D11 Layers- 
> ProductID: {3550f703-e582-4d05-9a08-453d09bdfdc6}
> ProductName: Thunderbird
> ReleaseChannel: beta
> SecondsSinceLastCrash: 654
> StartupTime: 1437568895
> SystemMemoryUsePercentage: 27
> Theme: classic/1.0
> Throttleable: 1
> TotalPageFile: 45194235904
> TotalPhysicalMemory: 34353840128
> TotalVirtualMemory: 4294836224
> URL: 
> Vendor: 
> Version: 37.0
> Winsock_LSP: MSAFD Tcpip [TCP/IP] : 2 : 1 :  
>  MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
>  MSAFD Tcpip [RAW/IP] : 2 : 3 :  
>  MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
>  MSAFD Tcpip [UDP/IPv6] : 2 : 2 :  
>  MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
>  RSVP TCPv6 Service Provider : 2 : 1 :  
>  RSVP TCP Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
>  RSVP UDPv6 Service Provider : 2 : 2 :  
>  RSVP UDP Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll
> useragent_locale: en-US
> 
> This report also contains technical information about the state of the
> application when it crashed.
> 
> 
> Expected results:
> 
> Should not crash - tried older version - still crashing.

Note: Tried Thunderbird in Safe Mode - Crashes - same as regular mode.
(Reporter)

Comment 3

2 years ago
Where do I get the Crash ID if its not in the report pasted above?
(Reporter)

Comment 4

2 years ago
Whitelist on my Address Book causing failure - deleted same - no crash.
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #1)
> 1. what is your crash ID?
>  see
> https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-
> reports
Flags: needinfo?(timw)
(Reporter)

Comment 6

2 years ago
Report ID 	Date Submitted
bp-fa1a4b80-151e-4737-a879-774862150722
	7/22/2015	11:30 AM
bp-d3baa649-234d-4ca4-a1f6-be5d42150722
	7/22/2015	11:28 AM
bp-eaf1797e-6b15-4f71-87fe-117132150722
	7/22/2015	11:26 AM
bp-1a36b4f0-9430-45ed-9222-375e42150722
	7/22/2015	11:24 AM
bp-7a7bd2a5-5418-482b-93a1-1c7992150722
	7/22/2015	8:43 AM
bp-654dabcc-04b8-44f7-893f-e811a2150722
	7/22/2015	8:43 AM
bp-be7c38e5-8f77-472e-b2e1-e005f2150722
	7/22/2015	8:31 AM
bp-f761e783-0248-4384-8a47-0e56a2150722
	7/22/2015	8:30 AM
bp-7bd4f1e8-387c-44b0-9fe7-230442150722
	7/22/2015	8:28 AM
bp-63674ec5-94e9-4c14-8e74-dfdd12150722
	7/22/2015	8:28 AM
bp-0326eab4-d037-4938-87df-9c5342150722
	7/22/2015	8:25 AM
bp-a868c3c6-ddf8-4517-b83b-86cd82150722
	7/22/2015	8:22 AM
bp-083a3c4e-2d87-4012-ad2a-3302f2150722
	7/22/2015	8:21 AM
bp-e3966416-9d16-4893-9787-f3de42150722
	7/22/2015	8:20 AM
bp-bd4c3d76-8a2a-4352-8af3-920492150722
	7/22/2015	8:19 AM
bp-b398ef59-f8e3-483d-b2d9-43ae42150722
	7/22/2015	8:18 AM
bp-5465c612-dcda-483b-b85f-88eb02150722
	7/22/2015	8:18 AM
fc8236f9-3207-48a1-aa2c-deb52a276d09
	7/22/2015	8:16 AM
169fc34f-a91d-4fce-ba0a-5c09330d82c7
	7/22/2015	8:04 AM
bp-94894e8a-5911-4053-9b1c-c1f692130929
	9/29/2013	4:56 PM
Flags: needinfo?(timw)
Thanks. The crash signature makes this the same as bug 1163132 which landed an exploratory patch.
bp-fa1a4b80-151e-4737-a879-774862150722 nsMsgFilterAfterTheFact::ContinueExecutionPrompt() 

So, was the whitelist using filters?  And can you easily resurrect that filter rule?
Or were you whitelisting junk processing?
Crash Signature: [@ nsMsgFilterAfterTheFact::ContinueExecutionPrompt() ]
Flags: needinfo?(timw)
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #7)
> Thanks. The crash signature makes this the same as bug 1163132 which landed
> an exploratory patch.
> bp-fa1a4b80-151e-4737-a879-774862150722 versoin 37.0b1
> nsMsgFilterAfterTheFact::ContinueExecutionPrompt() 
> 
> So, was the whitelist using filters?  And can you easily resurrect that
> filter rule?
> Or were you whitelisting junk processing?

but the signature changes in version 38
bp-5465c612-dcda-483b-b85f-88eb02150722 version 38.1.0
 nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsMsgApplyFiltersToMessages::RunNextFilter()
Crash Signature: [@ nsMsgFilterAfterTheFact::ContinueExecutionPrompt() ] → [@ nsMsgFilterAfterTheFact::ContinueExecutionPrompt() ] [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsMsgApplyFiltersToMessages::RunNextFilter()]
Component: Untriaged → Filters
Tim it looks like your crashing has stopped.
Did you do something whihc helped it to stop?
Summary: 38.1.0 just auto-installed upon reboot of system - now TBIRD is crashing!!! → TBIRD 38.1.0 crashing in Filters

Updated

2 years ago
Crash Signature: [@ nsMsgFilterAfterTheFact::ContinueExecutionPrompt() ] [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsMsgApplyFiltersToMessages::RunNextFilter()] → [@ nsMsgFilterAfterTheFact::ContinueExecutionPrompt() ] [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsMsgApplyFiltersToMessages::RunNextFilter()] [@ nsMsgFilterAfterTheFact::ContinueExecutionPrompt ] [@ nsCOMPtr_base::assign_with_AddRe…
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(timw)
Resolution: --- → DUPLICATE
Duplicate of bug: 1163132
See Also: → bug 1153820
You need to log in before you can comment on or make changes to this bug.