Closed Bug 1186426 Opened 4 years ago Closed 4 years ago

Avoid using D3D11 ANGLE on systems that require recreating the rendertargetview

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox42 --- fixed
firefox43 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

It turns out I accidentally landed https://bug1109718.bmoattachments.org/attachment.cgi?id=8630177 as part of another change. This should avoid the brokeness that was caused by that and allow us to simplify our changes to ANGLE.
Attachment #8637226 - Flags: review?(jgilbert)
Whiteboard: [gfx-noted]
Attachment #8637226 - Flags: review?(jgilbert) → review+
Comment on attachment 8637226 [details] [diff] [review]
Avoid using D3D11 ANGLE on systems that require recreating the rendertargetview

Approval Request Comment
[Feature/regressing bug #]: 8630177
[User impact if declined]: WebGL will be broken in some configurations
[Describe test coverage new/current, TreeHerder]: Minimal
[Risks and why]: Very low
Attachment #8637226 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/cefc315c3eee
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Comment on attachment 8637226 [details] [diff] [review]
Avoid using D3D11 ANGLE on systems that require recreating the rendertargetview

Taking anything which can improve the gfx situation, taking it. Thanks
Attachment #8637226 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.