Animated GIFs not hq-scaled

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: elbart, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Testcase: http://jsfiddle.net/7f70xcew/5/

Seen on Imgur when hovering over image-links to open a small preview, e.g. at the bottom of http://imgur.com/gallery/oihjn0V/comment/448438264

Comment 1

3 years ago
Could you attach a screenshot of what you see, please.
Flags: needinfo?(elbart)
This is not a bug; it's by design. To HQ scale animated GIFs would either consume drastically more memory (since we wouldn't be able to store frames as deltas) or would be very costly in terms of performance (since we'd have to redo the scaling of a frame every time we wanted to paint it, and that'd have to be done on the main thread as things stand now).

I don't see us changing this decision in the near future. The most analogous case is video, and we don't HQ scale video frames either, for the same reasons.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Flags: needinfo?(elbart)
You need to log in before you can comment on or make changes to this bug.