[Notifications] Delayed display of unread notifications on lockscreen after reboot

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: piwei, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing], [spark], [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8637388 [details]
logcat on Aries

Description:
Notifications are not immediately displayed on lockscreen after reboot. On Aries it takes about 3 seconds to show, and on Flame it takes about 7 seconds to show notifications on lockscreen.

STR:
1) Receive some notifications (screenshot, sms, etc); don't read them
2) Restart phone
3) Observe the lockscreen

Expected: Notifications should be immediately displayed as lockscreen is displayed

Actual: Lockscreen displays first, then after a moment come the notifications

See video:
https://www.youtube.com/watch?v=Q9yhxg8tagY

Attaching a logcat.

Repro rate: 5/5

Device: Flame (full flashed, 319MB, KK)
BuildID: 20150722010204
Gaia: 84c3bf622e211046d905803b34de5d331761f22d
Gecko: 8e5c888d0d89
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Aries (dogfood debug build, KK)
BuildID: 20150722123928
Gaia: b57aef5b7f52c40f88ee4c069ff722404e8e8521
Gecko: e7434cafdf2f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
(Reporter)

Comment 1

2 years ago
This issue does not occur on Flame 2.2.

Device: Flame 2.2
BuildID: 20150721162504
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: a73051740290
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-----

Root cause of issue is likely bug 1094759, because it caused bug 1172316, and I found this issue while verifying bug 1172316.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing], [spark], [systemsfe]
Thats an expected consequence of the boot changes on system app that were landed weeks ago. All the components, including the code that is calling resending of notifications is called much later.

The same explains the delay to display Sim status etc. I fear we cannot both make the boot to lockscreen faster and avoid this.
Thats 'expected behavior' now. We show the lock screen much quicker and don't wait for all the sub-modules to be loaded.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.