[Aries] ADB commands do not function until after display-reset or power-reset when enabling ADB in developer settings.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: onelson, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing], [Spark])

(Reporter)

Description

3 years ago
Description:
When the user attempts to access the phone via ADB devtools and USB connecting to a computer, they may observe that the phone is not recognized when plugged into a computer. This state appears to occur after performing a reset on an Aries device and enabling ADB, the phone will not be recognized. This has the impact of inconvenience on our testing department, as it requires an additional reboot of device in certain cases to continue testing, or an unconfirmed waiting time to resume testing/bugging on device.
This issue has been observed with different states:
* enable adb, laptop recognizes adb immediately
* enable adb, laptop recognizes adb device after tapping power and unlocking phone
* enable adb, laptop recognizes adb device after restarting device


Repro Steps:
1) Flash the RC4 Aries build -- user debug is enabled
2) Change OTA Channel to 'dogfood-latest'
3) Update to latest build -- user debug remains enabled
4) Observe 'ADB' on computer -- 'adb devices' in console
5) Reset device
6) Observe on reset, no adb access
7) Navigate to 'Developer Menu' in Settings
8) Enable 'ADB and DevTools' for Debugging via USB
9) Attempt to access 'adb devices' via console

Actual:
Device cannot be found via USB after enabling settings; requires reboot

Expected:
Device can be found via USB after enabling in Settings; no reboot required
-- or --
Device retains ADB after reset (probably against design)


Environmental Variables:
Device: Aries 2.5
BuildID: 20150722124026
Gaia: b57aef5b7f52c40f88ee4c069ff722404e8e8521
Gecko: 954706e7611c
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro Rate: 3/10
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Blocks: 1171119
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)

Comment 1

3 years ago
In case this may help you:

Some time back I experienced the same on my Debian laptop. I noticed that the androidrules.d entry had to be edited. Every time I switched base image the rules.d needed altering slightly as the reset created a second unrecognised device when I ran 
$ lsusb
to ID the device.

Comment 2

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.