If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bedrock isn't paying attention to the locale for GI_QA_GENERAL

RESOLVED INVALID

Status

www.mozilla.org
Pages & Content
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: lucyeoh, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
STR: 
1. Go to https://www.mozilla.org/es-ES/contribute/signup/
2. Fill it out

Expected: 
- participa@mozilla-hispano.org receives a Spanish email 

Actual: 
- Marcia receives Spanish email. 

My understanding is that this setup comes from Basket (https://basket.mozilla.org/admin/news/interest/10/) and so it looks like Bedrock is not paying attention to the right locale for GI_QA_GENERAL.
Can we turn off the Participation tests in Optimizely and rollback any code changes around those tests to fix this quickly?
I don't think this is participation tests. This seems to be because the lang files don't have the "2015_signup_form" tag. The view code is looking for that tag to use the new form, but I don't see it in any .lang file, so the new form is only on the en-US version of that page. You can see that the new form is nicely translated on the es-ES page by looking at the page on dev:

https://www-dev.allizom.org/es-ES/contribute/signup/

But because it's using the old form on prod it's sending the old email.

Flod: Do you know if maybe these tags were removed recently. It should be "2015_signup_form" in "mozorg/contribute/index.lang" files. I grepped and didn't find it anywhere, but clearly the code is looking for it:

https://github.com/mozilla/bedrock/blob/fe694c97b132aa91250f79788c2eac7539be71af/bedrock/mozorg/views.py#L238-L243
Flags: needinfo?(francesco.lodolo)
Component: Basket → Pages & Content
Product: Websites → www.mozilla.org
Version: unspecified → Production
(In reply to Paul McLanahan [:pmac] from comment #2)
> Flod: Do you know if maybe these tags were removed recently. It should be
> "2015_signup_form" in "mozorg/contribute/index.lang" files. I grepped and
> didn't find it anywhere, but clearly the code is looking for it:

They were never added, I'm waiting to set up the back-end for locales (I believe both Basked and Exact Target?).
https://bugzilla.mozilla.org/show_bug.cgi?id=1082122

Also, it turned out "autoresponders" are mandatory (they weren't with the current version), and

> Generic autoresponder takes 1 hour (or less to load in). If you create a different 
> auto-responder per interest (28 interests on the page), then it takes 28 hours to code, 
> load and set up the email content. 

We're able to use new page + old form because you hacked your way around it (thanks!), otherwise we'd be still using the old template.

Most of the people involved in that discussion are not in Mozilla anymore, to be honest I kind of lost hope to see that form enabled.
Flags: needinfo?(francesco.lodolo)
Oh right... I'd forgotten that whole mess :( So the answer is that this is the (unfortunately) expected behavior.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 5

2 years ago
Thanks all. There was fear that Marcia was getting all of the Spanish submissions from:

https://www.mozilla.org/es-ES/contribute/signup/

Which is not the new form, but instead is the work-around pmac put in place to unblock locales from using the new redesigned site (thank you pmac!). The timing of this alert from Marcia combined with the tests being run on /contribute made it seem that there was a connection here. Apologies for the alert.

After more investigation, Marcia is receiving the right emails in English, but has noticed that in her "Contribute Digest" emails (https://mail.mozilla.org/listinfo/contribute), there have been more Spanish submissions than usual.
You need to log in before you can comment on or make changes to this bug.