Closed Bug 1186675 Opened 5 years ago Closed 3 years ago

Intermittent leakcheck | default process: 6538467 bytes leaked (AnimationTimeline, AsyncLatencyLogger, AsyncStatement, AtomImpl, BackstagePass, ...)

Categories

(Core :: Disability Access APIs, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: KWierso, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, memory-leak)

Keywords: mlk
Blocks: 933741
It's unclear what is going on here, but this log for example <http://archive.mozilla.org/pub/firefox/tinderbox-builds/fx-team-win32-debug/1451390859/fx-team_xp-ix-debug_test-mochitest-devtools-chrome-3-bm109-tests1-windows-build432.txt.gz> has this page listed in the list of leaked URLs:

08:47:09     INFO -    http://mochi.test:8888/browser/devtools/client/responsivedesign/test/touch.html

Which is only used in <https://dxr.mozilla.org/mozilla-central/source/devtools/client/responsivedesign/test/browser_responsiveui_touch.js#7>, so moving to devtools for now.
Component: DOM: Service Workers → Developer Tools: Responsive Mode
Product: Core → Firefox
Component: Developer Tools: Responsive Mode → Disability Access APIs
Product: Firefox → Core
This bug seems to be an unfortunate dumping ground for various massive leaks. I'll try to think about a better way to distinguish these leaks.

Anyawys, in comment 74, Ehsan noted that all of the failures were in devtools stuff. However, starting at the start of 2016, as shown in comment 75 and onwards, these failures are primarily in Mochitest-other a11y tests, and the leaks have gotten much larger. In fact, the Moth leaks I saw seem to all happen in logs that also have a particular set of failures:

INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/jsat/test_gesture_tracker.html | Test timed out.
INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/jsat/test_live_regions.html | uncaught exception - Error: Only one top-level window could used with AccessFu at resource://gre/modules/accessibility/Utils.jsm:44
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/jsat/test_pointer_relay.html | uncaught exception - Error: Only one top-level window could used with AccessFu at resource://gre/modules/accessibility/Utils.jsm:44
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/jsat/test_quicknav_modes.html | uncaught exception - Error: Only one top-level window could used with AccessFu at resource://gre/modules/accessibility/Utils.jsm:44
Summary: Intermittent leakcheck | default process: 4227963 bytes leaked (AnimationTimeline, AsyncLatencyLogger, AsyncStatement, AtomImpl, BackstagePass, ...) → Intermittent leakcheck | default process: 6538467 bytes leaked (AnimationTimeline, AsyncLatencyLogger, AsyncStatement, AtomImpl, BackstagePass, ...)
See Also: → 1087608
Duplicate of this bug: 1122249
FWIW I had only inspected a few log files, not every single one of them.  It's very likely that soon people will start all of our leaks against this bug.  :(
(In reply to :Ehsan Akhgari from comment #80)
> FWIW I had only inspected a few log files, not every single one of them.

I just skimmed the list of oranges in comment 72, and the majority were in devtools. Compared to comment 72 where they are almost all in a11y tests.

> It's very likely that soon people will start all of our leaks against this
> bug.  :(

This is only a problem for leaks that are large enough to leak windows, which end up leaking a bunch of random stuff. There aren't too many of those, all things considered. I filed bug 1242726 to try to come up with a way to distinguish different window leaks.
I looked over the failures in comment 88.

- 26 look like bug 1087608.
- 2 failures in the directory dom/workers/test/serviceworkers on L64
- 7 failures on a try push by kats (the push has even more that weren't starred but look like the same thing). His try push has e10s force enabled so I think this is just known issues with e10s service worker tests leaking.
  https://treeherder.mozilla.org/#/jobs?repo=try&revision=9cd7ed658735&selectedJob=17714419
- 3 failures when browser/components/customizableui/test/browser_947914_button_print.js also fails.
See Also: → 1238707
Bug 1238707 will hopefully cover the leaks in service worker tests.
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.